xref: /linux/scripts/package/debian/rules (revision 1260ed77798502de9c98020040d2995008de10cc)
1#!/usr/bin/make -f
2# SPDX-License-Identifier: GPL-2.0-only
3
4# in case debian/rules is executed directly
5export DEB_RULES_REQUIRES_ROOT := no
6
7include debian/rules.vars
8
9ifneq (,$(filter-out parallel=1,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
10    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
11    MAKEFLAGS += -j$(NUMJOBS)
12endif
13
14# When KBUILD_VERBOSE is undefined (presumably you are directly working with
15# the debianized tree), show verbose logs unless DEB_BUILD_OPTION=terse is set.
16ifeq ($(origin KBUILD_VERBOSE),undefined)
17    ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
18        export KBUILD_VERBOSE := 1
19    else
20        Q := @
21    endif
22endif
23
24revision = $(shell dpkg-parsechangelog -S Version | sed -n 's/.*-//p')
25CROSS_COMPILE ?= $(filter-out $(DEB_BUILD_GNU_TYPE)-, $(DEB_HOST_GNU_TYPE)-)
26make-opts = ARCH=$(ARCH) KERNELRELEASE=$(KERNELRELEASE) \
27    $(addprefix KBUILD_BUILD_VERSION=,$(revision)) \
28    $(addprefix CROSS_COMPILE=,$(CROSS_COMPILE))
29
30binary-targets := $(addprefix binary-, image image-dbg headers libc-dev)
31
32all-packages = $(shell dh_listpackages)
33image-package = $(filter linux-image-% user-%, $(filter-out %-dbg, $(all-packages)))
34image-dbg-package = $(filter %-dbg, $(all-packages))
35libc-dev-package = $(filter linux-libc-dev, $(all-packages))
36headers-package = $(filter linux-headers-%, $(all-packages))
37
38mk-files = $(patsubst binary-%,debian/%.files,$1)
39package = $($(@:binary-%=%-package))
40
41# DH_OPTION is an environment variable common for all debhelper commands.
42# We could 'export' it, but here it is passed from the command line to clarify
43# which package is being processed in the build log.
44DH_OPTIONS = -p$(package)
45
46# Note: future removal of KDEB_COMPRESS
47# dpkg-deb >= 1.21.10 supports the DPKG_DEB_COMPRESSOR_TYPE environment
48# variable, which provides the same functionality as KDEB_COMPRESS. The
49# KDEB_COMPRESS variable will be removed in the future.
50define binary
51	$(Q)dh_testdir $(DH_OPTIONS)
52	$(Q)dh_testroot $(DH_OPTIONS)
53	$(Q)dh_prep $(DH_OPTIONS)
54	$(Q)+$(MAKE) $(make-opts) run-command KBUILD_RUN_COMMAND='+$$(srctree)/scripts/package/builddeb $(package)'
55	$(Q)dh_installdocs $(DH_OPTIONS)
56	$(Q)dh_installchangelogs $(DH_OPTIONS)
57	$(Q)dh_compress $(DH_OPTIONS)
58	$(Q)dh_fixperms $(DH_OPTIONS)
59	$(Q)dh_gencontrol $(DH_OPTIONS) -- -f$(call mk-files,$@)
60	$(Q)dh_md5sums $(DH_OPTIONS)
61	$(Q)dh_builddeb $(DH_OPTIONS) -- $(addprefix -Z,$(KDEB_COMPRESS))
62endef
63
64.PHONY: $(binary-targets)
65$(binary-targets): build-arch
66	$(Q)truncate -s0 $(call mk-files,$@)
67	$(if $(package),$(binary))
68
69.PHONY: binary binary-indep binary-arch
70binary: binary-arch binary-indep
71binary-indep: build-indep
72binary-arch: $(binary-targets)
73	$(Q)cat $(call mk-files,$^) > debian/files
74
75.PHONY: build build-indep build-arch
76build: build-arch build-indep
77build-indep:
78build-arch:
79	$(Q)$(MAKE) $(make-opts) olddefconfig
80	$(Q)$(MAKE) $(make-opts) $(if $(filter um,$(ARCH)),,headers) all
81
82.PHONY: clean
83clean:
84	$(Q)dh_clean
85	$(Q)rm -rf debian/deb-env.vars* debian/*.files
86	$(Q)$(MAKE) ARCH=$(ARCH) clean
87
88# If DEB_HOST_ARCH is empty, it is likely that debian/rules was executed
89# directly. Run 'dpkg-architecture --print-set --print-format=make' to
90# generate a makefile construct that exports all DEB_* variables.
91ifndef DEB_HOST_ARCH
92include debian/deb-env.vars
93
94debian/deb-env.vars:
95	$(Q)dpkg-architecture -a$$(cat debian/arch) --print-set --print-format=make > $@.tmp
96	$(Q)mv $@.tmp $@
97endif
98