1 /* SPDX-License-Identifier: GPL-2.0-or-later */ 2 /* 3 * INET An implementation of the TCP/IP protocol suite for the LINUX 4 * operating system. INET is implemented using the BSD Socket 5 * interface as the means of communication with the user level. 6 * 7 * Definitions for the TCP protocol. 8 * 9 * Version: @(#)tcp.h 1.0.2 04/28/93 10 * 11 * Author: Fred N. van Kempen, <waltje@uWalt.NL.Mugnet.ORG> 12 */ 13 #ifndef _LINUX_TCP_H 14 #define _LINUX_TCP_H 15 16 17 #include <linux/skbuff.h> 18 #include <linux/win_minmax.h> 19 #include <net/sock.h> 20 #include <net/inet_connection_sock.h> 21 #include <net/inet_timewait_sock.h> 22 #include <uapi/linux/tcp.h> 23 24 static inline struct tcphdr *tcp_hdr(const struct sk_buff *skb) 25 { 26 return (struct tcphdr *)skb_transport_header(skb); 27 } 28 29 static inline unsigned int __tcp_hdrlen(const struct tcphdr *th) 30 { 31 return th->doff * 4; 32 } 33 34 static inline unsigned int tcp_hdrlen(const struct sk_buff *skb) 35 { 36 return __tcp_hdrlen(tcp_hdr(skb)); 37 } 38 39 static inline struct tcphdr *inner_tcp_hdr(const struct sk_buff *skb) 40 { 41 return (struct tcphdr *)skb_inner_transport_header(skb); 42 } 43 44 static inline unsigned int inner_tcp_hdrlen(const struct sk_buff *skb) 45 { 46 return inner_tcp_hdr(skb)->doff * 4; 47 } 48 49 /** 50 * skb_tcp_all_headers - Returns size of all headers for a TCP packet 51 * @skb: buffer 52 * 53 * Used in TX path, for a packet known to be a TCP one. 54 * 55 * if (skb_is_gso(skb)) { 56 * int hlen = skb_tcp_all_headers(skb); 57 * ... 58 */ 59 static inline int skb_tcp_all_headers(const struct sk_buff *skb) 60 { 61 return skb_transport_offset(skb) + tcp_hdrlen(skb); 62 } 63 64 /** 65 * skb_inner_tcp_all_headers - Returns size of all headers for an encap TCP packet 66 * @skb: buffer 67 * 68 * Used in TX path, for a packet known to be a TCP one. 69 * 70 * if (skb_is_gso(skb) && skb->encapsulation) { 71 * int hlen = skb_inner_tcp_all_headers(skb); 72 * ... 73 */ 74 static inline int skb_inner_tcp_all_headers(const struct sk_buff *skb) 75 { 76 return skb_inner_transport_offset(skb) + inner_tcp_hdrlen(skb); 77 } 78 79 static inline unsigned int tcp_optlen(const struct sk_buff *skb) 80 { 81 return (tcp_hdr(skb)->doff - 5) * 4; 82 } 83 84 /* TCP Fast Open */ 85 #define TCP_FASTOPEN_COOKIE_MIN 4 /* Min Fast Open Cookie size in bytes */ 86 #define TCP_FASTOPEN_COOKIE_MAX 16 /* Max Fast Open Cookie size in bytes */ 87 #define TCP_FASTOPEN_COOKIE_SIZE 8 /* the size employed by this impl. */ 88 89 /* TCP Fast Open Cookie as stored in memory */ 90 struct tcp_fastopen_cookie { 91 __le64 val[DIV_ROUND_UP(TCP_FASTOPEN_COOKIE_MAX, sizeof(u64))]; 92 s8 len; 93 bool exp; /* In RFC6994 experimental option format */ 94 }; 95 96 /* This defines a selective acknowledgement block. */ 97 struct tcp_sack_block_wire { 98 __be32 start_seq; 99 __be32 end_seq; 100 }; 101 102 struct tcp_sack_block { 103 u32 start_seq; 104 u32 end_seq; 105 }; 106 107 /*These are used to set the sack_ok field in struct tcp_options_received */ 108 #define TCP_SACK_SEEN (1 << 0) /*1 = peer is SACK capable, */ 109 #define TCP_DSACK_SEEN (1 << 2) /*1 = DSACK was received from peer*/ 110 111 struct tcp_options_received { 112 /* PAWS/RTTM data */ 113 int ts_recent_stamp;/* Time we stored ts_recent (for aging) */ 114 u32 ts_recent; /* Time stamp to echo next */ 115 u32 rcv_tsval; /* Time stamp value */ 116 u32 rcv_tsecr; /* Time stamp echo reply */ 117 u16 saw_tstamp : 1, /* Saw TIMESTAMP on last packet */ 118 tstamp_ok : 1, /* TIMESTAMP seen on SYN packet */ 119 dsack : 1, /* D-SACK is scheduled */ 120 wscale_ok : 1, /* Wscale seen on SYN packet */ 121 sack_ok : 3, /* SACK seen on SYN packet */ 122 smc_ok : 1, /* SMC seen on SYN packet */ 123 snd_wscale : 4, /* Window scaling received from sender */ 124 rcv_wscale : 4; /* Window scaling to send to receiver */ 125 u8 accecn:6, /* AccECN index in header, 0=no options */ 126 saw_unknown:1, /* Received unknown option */ 127 unused:1; 128 u8 num_sacks; /* Number of SACK blocks */ 129 u16 user_mss; /* mss requested by user in ioctl */ 130 u16 mss_clamp; /* Maximal mss, negotiated at connection setup */ 131 }; 132 133 static inline void tcp_clear_options(struct tcp_options_received *rx_opt) 134 { 135 rx_opt->tstamp_ok = rx_opt->sack_ok = 0; 136 rx_opt->wscale_ok = rx_opt->snd_wscale = 0; 137 #if IS_ENABLED(CONFIG_SMC) 138 rx_opt->smc_ok = 0; 139 #endif 140 } 141 142 /* This is the max number of SACKS that we'll generate and process. It's safe 143 * to increase this, although since: 144 * size = TCPOLEN_SACK_BASE_ALIGNED (4) + n * TCPOLEN_SACK_PERBLOCK (8) 145 * only four options will fit in a standard TCP header */ 146 #define TCP_NUM_SACKS 4 147 148 struct tcp_request_sock_ops; 149 150 struct tcp_request_sock { 151 struct inet_request_sock req; 152 const struct tcp_request_sock_ops *af_specific; 153 u64 snt_synack; /* first SYNACK sent time */ 154 bool tfo_listener; 155 bool is_mptcp; 156 bool req_usec_ts; 157 #if IS_ENABLED(CONFIG_MPTCP) 158 bool drop_req; 159 #endif 160 u32 txhash; 161 u32 rcv_isn; 162 u32 snt_isn; 163 u32 ts_off; 164 u32 snt_tsval_first; 165 u32 snt_tsval_last; 166 u32 last_oow_ack_time; /* last SYNACK */ 167 u32 rcv_nxt; /* the ack # by SYNACK. For 168 * FastOpen it's the seq# 169 * after data-in-SYN. 170 */ 171 u8 syn_tos; 172 bool accecn_ok; 173 u8 syn_ect_snt: 2, 174 syn_ect_rcv: 2, 175 accecn_fail_mode:4; 176 u8 saw_accecn_opt :2; 177 #ifdef CONFIG_TCP_AO 178 u8 ao_keyid; 179 u8 ao_rcv_next; 180 bool used_tcp_ao; 181 #endif 182 }; 183 184 #define tcp_rsk(ptr) container_of_const(ptr, struct tcp_request_sock, req.req) 185 186 static inline bool tcp_rsk_used_ao(const struct request_sock *req) 187 { 188 #ifndef CONFIG_TCP_AO 189 return false; 190 #else 191 return tcp_rsk(req)->used_tcp_ao; 192 #endif 193 } 194 195 #define TCP_RMEM_TO_WIN_SCALE 8 196 197 struct tcp_sock { 198 /* Cacheline organization can be found documented in 199 * Documentation/networking/net_cachelines/tcp_sock.rst. 200 * Please update the document when adding new fields. 201 */ 202 203 /* inet_connection_sock has to be the first member of tcp_sock */ 204 struct inet_connection_sock inet_conn; 205 206 /* TX read-mostly hotpath cache lines */ 207 __cacheline_group_begin(tcp_sock_read_tx); 208 u32 max_window; /* Maximal window ever seen from peer */ 209 u32 rcv_ssthresh; /* Current window clamp */ 210 u32 reordering; /* Packet reordering metric. */ 211 u32 notsent_lowat; /* TCP_NOTSENT_LOWAT */ 212 u16 gso_segs; /* Max number of segs per GSO packet */ 213 /* from STCP, retrans queue hinting */ 214 struct sk_buff *retransmit_skb_hint; 215 #if defined(CONFIG_TLS_DEVICE) 216 void (*tcp_clean_acked)(struct sock *sk, u32 acked_seq); 217 #endif 218 __cacheline_group_end(tcp_sock_read_tx); 219 220 /* TXRX read-mostly hotpath cache lines */ 221 __cacheline_group_begin(tcp_sock_read_txrx); 222 u32 tsoffset; /* timestamp offset */ 223 u32 snd_wnd; /* The window we expect to receive */ 224 u32 mss_cache; /* Cached effective mss, not including SACKS */ 225 u32 snd_cwnd; /* Sending congestion window */ 226 u32 prr_out; /* Total number of pkts sent during Recovery. */ 227 u32 lost_out; /* Lost packets */ 228 u32 sacked_out; /* SACK'd packets */ 229 u16 tcp_header_len; /* Bytes of tcp header to send */ 230 u8 scaling_ratio; /* see tcp_win_from_space() */ 231 u8 repair : 1, 232 tcp_usec_ts : 1, /* TSval values in usec */ 233 is_sack_reneg:1, /* in recovery from loss with SACK reneg? */ 234 is_cwnd_limited:1,/* forward progress limited by snd_cwnd? */ 235 recvmsg_inq : 1;/* Indicate # of bytes in queue upon recvmsg */ 236 #ifdef CONFIG_BPF 237 u32 bpf_tcp_ops_flags; 238 #define BPF_TCP_OPS_TEST_FLAG(TP, ARG) \ 239 (READ_ONCE((TP)->bpf_tcp_ops_flags) & BPF_TCP_OPS_FLAG_ ## ARG) 240 #else 241 #define BPF_TCP_OPS_TEST_FLAG(TP, ARG) (0) 242 #endif 243 __cacheline_group_end(tcp_sock_read_txrx); 244 245 /* RX read-mostly hotpath cache lines */ 246 __cacheline_group_begin(tcp_sock_read_rx); 247 u32 copied_seq; /* Head of yet unread data */ 248 u32 snd_wl1; /* Sequence for window update */ 249 u32 tlp_high_seq; /* snd_nxt at the time of TLP */ 250 u32 rttvar_us; /* smoothed mdev_max */ 251 u32 retrans_out; /* Retransmitted packets out */ 252 u16 advmss; /* Advertised MSS */ 253 u16 urg_data; /* Saved octet of OOB data and control flags */ 254 u32 lost; /* Total data packets lost incl. rexmits */ 255 u32 snd_ssthresh; /* Slow start size threshold */ 256 struct minmax rtt_min; 257 /* OOO segments go in this rbtree. Socket lock must be held. */ 258 struct rb_root out_of_order_queue; 259 __cacheline_group_end(tcp_sock_read_rx); 260 261 /* TX read-write hotpath cache lines */ 262 __cacheline_group_begin(tcp_sock_write_tx) ____cacheline_aligned; 263 u32 delivered; /* Total data packets delivered incl. rexmits */ 264 u32 delivered_ce; /* Like the above but only ECE marked packets */ 265 u64 bytes_acked; /* RFC4898 tcpEStatsAppHCThruOctetsAcked 266 * sum(delta(snd_una)), or how many bytes 267 * were acked. 268 */ 269 u64 bytes_sent; /* RFC4898 tcpEStatsPerfHCDataOctetsOut 270 * total number of data bytes sent. 271 */ 272 u64 first_tx_mstamp; /* start of window send phase */ 273 u64 delivered_mstamp; /* time we reached "delivered" */ 274 u32 data_segs_out; /* RFC4898 tcpEStatsPerfDataSegsOut 275 * total number of data segments sent. 276 */ 277 u32 snd_sml; /* Last byte of the most recently transmitted small packet */ 278 u8 chrono_type; /* current chronograph type */ 279 u8 tcp_nospace; /* mirrors SOCK_NOSPACE, must be set whenever 280 * SOCK_NOSPACE is set. 281 */ 282 u32 chrono_start; /* Start time in jiffies of a TCP chrono */ 283 u32 chrono_stat[3]; /* Time in jiffies for chrono_stat stats */ 284 u32 write_seq; /* Tail(+1) of data held in tcp send buffer */ 285 u32 pushed_seq; /* Last pushed seq, required to talk to windows */ 286 u32 lsndtime; /* timestamp of last sent data packet (for restart window) */ 287 u32 mdev_us; /* mean deviation of RTT, scaled by 4 (<< 2) in usecs */ 288 u32 rtt_seq; /* sequence number to update rttvar */ 289 u32 max_packets_out; /* max packets_out in last window */ 290 u32 cwnd_usage_seq; /* right edge of cwnd usage tracking flight */ 291 u32 rate_delivered; /* saved rate sample: packets delivered */ 292 u32 rate_interval_us; /* saved rate sample: time elapsed */ 293 u64 tcp_wstamp_ns; /* departure time for next sent data packet */ 294 u64 accecn_opt_tstamp; /* Last AccECN option sent timestamp */ 295 struct list_head tsorted_sent_queue; /* time-sorted sent but un-SACKed skbs */ 296 struct sk_buff *highest_sack; /* skb just after the highest 297 * skb with SACKed bit set 298 * (validity guaranteed only if 299 * sacked_out > 0) 300 */ 301 u8 ecn_flags; /* ECN status bits. */ 302 __cacheline_group_end(tcp_sock_write_tx); 303 304 /* TXRX read-write hotpath cache lines */ 305 __cacheline_group_begin(tcp_sock_write_txrx); 306 /* 307 * Header prediction flags 308 * 0x5?10 << 16 + snd_wnd in net byte order 309 */ 310 u8 nonagle : 4,/* Disable Nagle algorithm? */ 311 rate_app_limited:1; /* rate_{delivered,interval_us} limited? */ 312 u8 received_ce_pending:4, /* Not yet transmit cnt of received_ce */ 313 accecn_opt_sent_w_dsack:1,/* Sent ACCECN opt in previous ACK w/ D-SACK */ 314 unused2:3; 315 u8 accecn_minlen:2,/* Minimum length of AccECN option sent */ 316 est_ecnfield:2,/* ECN field for AccECN delivered estimates */ 317 accecn_opt_demand:2,/* Demand AccECN option for n next ACKs */ 318 prev_ecnfield:2; /* ECN bits from the previous segment */ 319 __be32 pred_flags; 320 u64 tcp_clock_cache; /* cache last tcp_clock_ns() (see tcp_mstamp_refresh()) */ 321 u64 tcp_mstamp; /* most recent packet received/sent */ 322 u32 rcv_nxt; /* What we want to receive next */ 323 u32 snd_nxt; /* Next sequence we send */ 324 u32 snd_una; /* First byte we want an ack for */ 325 u32 window_clamp; /* Maximal window to advertise */ 326 u32 srtt_us; /* smoothed round trip time << 3 in usecs */ 327 u32 packets_out; /* Packets which are "in flight" */ 328 u32 snd_up; /* Urgent pointer */ 329 u32 received_ce; /* Like the above but for rcvd CE marked pkts */ 330 u32 received_ecn_bytes[3]; /* received byte counters for three ECN 331 * types: INET_ECN_ECT_1, INET_ECN_ECT_0, 332 * and INET_ECN_CE 333 */ 334 u32 app_limited; /* limited until "delivered" reaches this val */ 335 u32 rcv_wnd; /* Current receiver window */ 336 u32 rcv_mwnd_seq; /* Maximum window sequence number (RFC 7323, 337 * section 2.4, receiver requirements) 338 */ 339 u32 rcv_tstamp; /* timestamp of last received ACK (for keepalives) */ 340 /* 341 * Options received (usually on last packet, some only on SYN packets). 342 */ 343 struct tcp_options_received rx_opt; 344 u32 segs_in; /* RFC4898 tcpEStatsPerfSegsIn 345 * total number of segments in. 346 */ 347 u32 segs_out; /* RFC4898 tcpEStatsPerfSegsOut 348 * The total number of segments sent. 349 */ 350 __cacheline_group_end(tcp_sock_write_txrx); 351 352 /* RX read-write hotpath cache lines */ 353 __cacheline_group_begin(tcp_sock_write_rx) __aligned(8); 354 u64 bytes_received; 355 /* RFC4898 tcpEStatsAppHCThruOctetsReceived 356 * sum(delta(rcv_nxt)), or how many bytes 357 * were acked. 358 */ 359 u32 data_segs_in; /* RFC4898 tcpEStatsPerfDataSegsIn 360 * total number of data segments in. 361 */ 362 u32 rcv_wup; /* rcv_nxt on last window update sent */ 363 u32 rcv_rtt_last_tsecr; 364 u32 delivered_ecn_bytes[3]; 365 u16 pkts_acked_ewma;/* Pkts acked EWMA for AccECN cep heuristic */ 366 struct { 367 u32 rtt_us; 368 u32 seq; 369 u64 time; 370 } rcv_rtt_est; 371 /* Receiver queue space */ 372 struct { 373 int space; 374 u32 seq; 375 u64 time; 376 } rcvq_space; 377 __cacheline_group_end(tcp_sock_write_rx); 378 /* End of Hot Path */ 379 380 /* 381 * RFC793 variables by their proper names. This means you can 382 * read the code and the spec side by side (and laugh ...) 383 * See RFC793 and RFC1122. The RFC writes these in capitals. 384 */ 385 u32 dsack_dups; /* RFC4898 tcpEStatsStackDSACKDups 386 * total number of DSACK blocks received 387 */ 388 u32 compressed_ack_rcv_nxt; 389 struct list_head tsq_node; /* anchor in tsq_tasklet.head list */ 390 391 /* Information of the most recently (s)acked skb */ 392 struct tcp_rack { 393 u64 mstamp; /* (Re)sent time of the skb */ 394 u32 rtt_us; /* Associated RTT */ 395 u32 end_seq; /* Ending TCP sequence of the skb */ 396 u32 last_delivered; /* tp->delivered at last reo_wnd adj */ 397 u8 reo_wnd_steps; /* Allowed reordering window */ 398 #define TCP_RACK_RECOVERY_THRESH 16 399 u8 reo_wnd_persist:5, /* No. of recovery since last adj */ 400 dsack_seen:1, /* Whether DSACK seen after last adj */ 401 advanced:1; /* mstamp advanced since last lost marking */ 402 } rack; 403 u8 compressed_ack; 404 u8 dup_ack_counter:2, 405 tlp_retrans:1, /* TLP is a retransmission */ 406 syn_ect_snt:2, /* AccECN ECT memory, only */ 407 syn_ect_rcv:2; /* ... needed during 3WHS + first seqno */ 408 u8 thin_lto : 1,/* Use linear timeouts for thin streams */ 409 fastopen_connect:1, /* FASTOPEN_CONNECT sockopt */ 410 fastopen_no_cookie:1, /* Allow send/recv SYN+data without a cookie */ 411 fastopen_client_fail:2, /* reason why fastopen failed */ 412 frto : 1;/* F-RTO (RFC5682) activated in CA_Loss */ 413 u8 repair_queue; 414 u8 save_syn:2, /* Save headers of SYN packet */ 415 syn_data:1, /* SYN includes data */ 416 syn_fastopen:1, /* SYN includes Fast Open option */ 417 syn_fastopen_exp:1,/* SYN includes Fast Open exp. option */ 418 syn_fastopen_ch:1, /* Active TFO re-enabling probe */ 419 syn_data_acked:1,/* data in SYN is acked by SYN-ACK */ 420 syn_fastopen_child:1; /* created TFO passive child socket */ 421 422 u8 keepalive_probes; /* num of allowed keep alive probes */ 423 u8 accecn_fail_mode:4, /* AccECN failure handling */ 424 saw_accecn_opt:2; /* An AccECN option was seen */ 425 u32 tcp_tx_delay; /* delay (in usec) added to TX packets */ 426 427 /* RTT measurement */ 428 u32 mdev_max_us; /* maximal mdev for the last rtt period */ 429 430 u32 reord_seen; /* number of data packet reordering events */ 431 432 /* 433 * Slow start and congestion control (see also Nagle, and Karn & Partridge) 434 */ 435 u32 snd_cwnd_cnt; /* Linear increase counter */ 436 u32 snd_cwnd_clamp; /* Do not allow snd_cwnd to grow above this */ 437 u32 snd_cwnd_used; 438 u32 snd_cwnd_stamp; 439 u32 prior_cwnd; /* cwnd right before starting loss recovery */ 440 u32 prr_delivered; /* Number of newly delivered packets to 441 * receiver in Recovery. */ 442 u32 last_oow_ack_time; /* timestamp of last out-of-window ACK */ 443 444 struct hrtimer pacing_timer; 445 struct hrtimer compressed_ack_timer; 446 447 struct sk_buff *ooo_last_skb; /* cache rb_last(out_of_order_queue) */ 448 449 /* SACKs data, these 2 need to be together (see tcp_options_write) */ 450 struct tcp_sack_block duplicate_sack[1]; /* D-SACK block */ 451 struct tcp_sack_block selective_acks[4]; /* The SACKS themselves*/ 452 453 struct tcp_sack_block recv_sack_cache[4]; 454 455 u32 prior_ssthresh; /* ssthresh saved at recovery start */ 456 u32 high_seq; /* snd_nxt at onset of congestion */ 457 458 u32 retrans_stamp; /* Timestamp of the last retransmit, 459 * also used in SYN-SENT to remember stamp of 460 * the first SYN. */ 461 u32 undo_marker; /* snd_una upon a new recovery episode. */ 462 int undo_retrans; /* number of undoable retransmissions. */ 463 u32 mtu_info; /* We received an ICMP_FRAG_NEEDED / ICMPV6_PKT_TOOBIG 464 * while socket was owned by user. 465 */ 466 u64 bytes_retrans; /* RFC4898 tcpEStatsPerfOctetsRetrans 467 * Total data bytes retransmitted 468 */ 469 u32 total_retrans; /* Total retransmits for entire connection */ 470 u32 rto_stamp; /* Start time (ms) of last CA_Loss recovery */ 471 u16 total_rto; /* Total number of RTO timeouts, including 472 * SYN/SYN-ACK and recurring timeouts. 473 */ 474 u16 total_rto_recoveries; /* Total number of RTO recoveries, 475 * including any unfinished recovery. 476 */ 477 u32 total_rto_time; /* ms spent in (completed) RTO recoveries. */ 478 479 u32 urg_seq; /* Seq of received urgent pointer */ 480 unsigned int keepalive_time; /* time before keep alive takes place */ 481 unsigned int keepalive_intvl; /* time interval between keep alive probes */ 482 483 int linger2; 484 485 486 /* Sock_ops bpf program related variables */ 487 #ifdef CONFIG_BPF 488 u8 bpf_sock_ops_cb_flags; /* Control calling BPF programs 489 * values defined in uapi/linux/tcp.h 490 */ 491 u8 bpf_chg_cc_inprogress:1; /* In the middle of 492 * bpf_setsockopt(TCP_CONGESTION), 493 * it is to avoid the bpf_tcp_cc->init() 494 * to recur itself by calling 495 * bpf_setsockopt(TCP_CONGESTION, "itself"). 496 */ 497 #define BPF_SOCK_OPS_TEST_FLAG(TP, ARG) (TP->bpf_sock_ops_cb_flags & ARG) 498 #else 499 #define BPF_SOCK_OPS_TEST_FLAG(TP, ARG) 0 500 #endif 501 502 u16 timeout_rehash; /* Timeout-triggered rehash attempts */ 503 504 u32 rcv_ooopack; /* Received out-of-order packets, for tcpinfo */ 505 506 /* TCP-specific MTU probe information. */ 507 struct { 508 u32 probe_seq_start; 509 u32 probe_seq_end; 510 } mtu_probe; 511 u32 plb_rehash; /* PLB-triggered rehash attempts */ 512 #if IS_ENABLED(CONFIG_MPTCP) 513 bool is_mptcp; 514 #endif 515 #if IS_ENABLED(CONFIG_SMC) 516 bool syn_smc; /* SYN includes SMC */ 517 bool (*smc_hs_congested)(const struct sock *sk); 518 #endif 519 520 #if defined(CONFIG_TCP_MD5SIG) || defined(CONFIG_TCP_AO) 521 /* TCP AF-Specific parts; only used by TCP-AO/MD5 Signature support so far */ 522 const struct tcp_sock_af_ops *af_specific; 523 524 #ifdef CONFIG_TCP_MD5SIG 525 /* TCP MD5 Signature Option information */ 526 struct tcp_md5sig_info __rcu *md5sig_info; 527 #endif 528 #ifdef CONFIG_TCP_AO 529 struct tcp_ao_info __rcu *ao_info; 530 #endif 531 #endif 532 533 /* TCP fastopen related information */ 534 struct tcp_fastopen_request *fastopen_req; 535 /* fastopen_rsk points to request_sock that resulted in this big 536 * socket. Used to retransmit SYNACKs etc. 537 */ 538 struct request_sock __rcu *fastopen_rsk; 539 struct saved_syn *saved_syn; 540 }; 541 542 enum tsq_enum { 543 TSQ_THROTTLED, 544 TSQ_QUEUED, 545 TCP_TSQ_DEFERRED, /* tcp_tasklet_func() found socket was owned */ 546 TCP_WRITE_TIMER_DEFERRED, /* tcp_write_timer() found socket was owned */ 547 TCP_DELACK_TIMER_DEFERRED, /* tcp_delack_timer() found socket was owned */ 548 TCP_MTU_REDUCED_DEFERRED, /* tcp_v{4|6}_err() could not call 549 * tcp_v{4|6}_mtu_reduced() 550 */ 551 TCP_ACK_DEFERRED, /* TX pure ack is deferred */ 552 }; 553 554 enum tsq_flags { 555 TSQF_THROTTLED = BIT(TSQ_THROTTLED), 556 TSQF_QUEUED = BIT(TSQ_QUEUED), 557 TCPF_TSQ_DEFERRED = BIT(TCP_TSQ_DEFERRED), 558 TCPF_WRITE_TIMER_DEFERRED = BIT(TCP_WRITE_TIMER_DEFERRED), 559 TCPF_DELACK_TIMER_DEFERRED = BIT(TCP_DELACK_TIMER_DEFERRED), 560 TCPF_MTU_REDUCED_DEFERRED = BIT(TCP_MTU_REDUCED_DEFERRED), 561 TCPF_ACK_DEFERRED = BIT(TCP_ACK_DEFERRED), 562 }; 563 564 /* Flags of interest for tcp_release_cb() */ 565 #define TCP_DEFERRED_ALL (TCPF_TSQ_DEFERRED | \ 566 TCPF_WRITE_TIMER_DEFERRED | \ 567 TCPF_DELACK_TIMER_DEFERRED | \ 568 TCPF_MTU_REDUCED_DEFERRED | \ 569 TCPF_ACK_DEFERRED) 570 571 #define tcp_sk(ptr) container_of_const(ptr, struct tcp_sock, inet_conn.icsk_inet.sk) 572 573 /* Variant of tcp_sk() upgrading a const sock to a read/write tcp socket. 574 * Used in context of (lockless) tcp listeners. 575 */ 576 #define tcp_sk_rw(ptr) container_of(ptr, struct tcp_sock, inet_conn.icsk_inet.sk) 577 578 struct tcp_timewait_sock { 579 struct inet_timewait_sock tw_sk; 580 #define tw_rcv_nxt tw_sk.__tw_common.skc_tw_rcv_nxt 581 #define tw_snd_nxt tw_sk.__tw_common.skc_tw_snd_nxt 582 u32 tw_rcv_wnd; 583 u32 tw_ts_offset; 584 u32 tw_ts_recent; 585 586 /* The time we sent the last out-of-window ACK: */ 587 u32 tw_last_oow_ack_time; 588 589 int tw_ts_recent_stamp; 590 u32 tw_tx_delay; 591 #ifdef CONFIG_TCP_MD5SIG 592 struct tcp_md5sig_key *tw_md5_key; 593 #endif 594 #ifdef CONFIG_TCP_AO 595 struct tcp_ao_info __rcu *ao_info; 596 #endif 597 }; 598 599 static inline struct tcp_timewait_sock *tcp_twsk(const struct sock *sk) 600 { 601 return (struct tcp_timewait_sock *)sk; 602 } 603 604 static inline bool tcp_passive_fastopen(const struct sock *sk) 605 { 606 return sk->sk_state == TCP_SYN_RECV && 607 rcu_access_pointer(tcp_sk(sk)->fastopen_rsk) != NULL; 608 } 609 610 static inline void fastopen_queue_tune(struct sock *sk, int backlog) 611 { 612 struct request_sock_queue *queue = &inet_csk(sk)->icsk_accept_queue; 613 int somaxconn = READ_ONCE(sock_net(sk)->core.sysctl_somaxconn); 614 615 WRITE_ONCE(queue->fastopenq.max_qlen, min_t(unsigned int, backlog, somaxconn)); 616 } 617 618 static inline void tcp_move_syn(struct tcp_sock *tp, 619 struct request_sock *req) 620 { 621 tp->saved_syn = req->saved_syn; 622 req->saved_syn = NULL; 623 } 624 625 static inline void tcp_saved_syn_free(struct tcp_sock *tp) 626 { 627 kfree(tp->saved_syn); 628 tp->saved_syn = NULL; 629 } 630 631 static inline u32 tcp_saved_syn_len(const struct saved_syn *saved_syn) 632 { 633 return saved_syn->mac_hdrlen + saved_syn->network_hdrlen + 634 saved_syn->tcp_hdrlen; 635 } 636 637 struct sk_buff *tcp_get_timestamping_opt_stats(const struct sock *sk, 638 const struct sk_buff *orig_skb, 639 const struct sk_buff *ack_skb); 640 641 static inline u16 tcp_mss_clamp(const struct tcp_sock *tp, u16 mss) 642 { 643 /* We use READ_ONCE() here because socket might not be locked. 644 * This happens for listeners. 645 */ 646 u16 user_mss = READ_ONCE(tp->rx_opt.user_mss); 647 648 return (user_mss && user_mss < mss) ? user_mss : mss; 649 } 650 651 int tcp_skb_shift(struct sk_buff *to, struct sk_buff *from, int pcount, 652 int shiftlen); 653 654 void __tcp_sock_set_cork(struct sock *sk, bool on); 655 void tcp_sock_set_cork(struct sock *sk, bool on); 656 int tcp_sock_set_keepcnt(struct sock *sk, int val); 657 int tcp_sock_set_keepidle_locked(struct sock *sk, int val); 658 int tcp_sock_set_keepidle(struct sock *sk, int val); 659 int tcp_sock_set_keepintvl(struct sock *sk, int val); 660 void __tcp_sock_set_nodelay(struct sock *sk, bool on); 661 void tcp_sock_set_nodelay(struct sock *sk); 662 void tcp_sock_set_quickack(struct sock *sk, int val); 663 int tcp_sock_set_syncnt(struct sock *sk, int val); 664 int tcp_sock_set_user_timeout(struct sock *sk, int val); 665 int tcp_sock_set_maxseg(struct sock *sk, int val); 666 667 static inline bool dst_tcp_usec_ts(const struct dst_entry *dst) 668 { 669 return dst_feature(dst, RTAX_FEATURE_TCP_USEC_TS); 670 } 671 672 #endif /* _LINUX_TCP_H */ 673