xref: /titanic_44/usr/src/pkg/manifests/system-zones.mf (revision 0dc2366f7b9f9f36e10909b1e95edbf2a261c2ac)
1#
2# CDDL HEADER START
3#
4# The contents of this file are subject to the terms of the
5# Common Development and Distribution License (the "License").
6# You may not use this file except in compliance with the License.
7#
8# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
9# or http://www.opensolaris.org/os/licensing.
10# See the License for the specific language governing permissions
11# and limitations under the License.
12#
13# When distributing Covered Code, include this CDDL HEADER in each
14# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
15# If applicable, add the following below this CDDL HEADER, with the
16# fields enclosed by brackets "[]" replaced with your own identifying
17# information: Portions Copyright [yyyy] [name of copyright owner]
18#
19# CDDL HEADER END
20#
21
22#
23# Copyright 2010 Sun Microsystems, Inc.  All rights reserved.
24# Use is subject to license terms.
25#
26
27set name=pkg.fmri value=pkg:/system/zones@$(PKGVERS)
28set name=pkg.description value="Solaris Zones Configuration and Administration"
29set name=pkg.summary value="Solaris Zones"
30set name=info.classification value=org.opensolaris.category.2008:System/Core
31set name=variant.arch value=$(ARCH)
32set name=variant.opensolaris.zone value=global value=nonglobal
33dir path=etc group=sys opensolaris.zone=global variant.opensolaris.zone=global
34dir path=etc/brand group=sys opensolaris.zone=global \
35    variant.opensolaris.zone=global
36dir path=etc/zones group=sys opensolaris.zone=global \
37    variant.opensolaris.zone=global
38dir path=lib opensolaris.zone=global variant.opensolaris.zone=global
39dir path=lib/svc opensolaris.zone=global variant.opensolaris.zone=global
40dir path=lib/svc/method opensolaris.zone=global variant.opensolaris.zone=global
41dir path=usr group=sys
42dir path=usr/bin
43dir path=usr/kernel group=sys
44dir path=usr/kernel/drv group=sys
45dir path=usr/kernel/drv/$(ARCH64) group=sys
46dir path=usr/lib
47dir path=usr/lib/$(ARCH64)
48dir path=usr/lib/brand
49dir path=usr/lib/brand/ipkg group=bin
50dir path=usr/lib/brand/shared group=sys
51dir path=usr/lib/zones
52dir path=usr/sbin
53dir path=usr/share group=sys
54dir path=usr/share/lib group=sys
55dir path=usr/share/lib/xml group=sys
56dir path=usr/share/lib/xml/dtd group=sys
57dir path=var group=sys opensolaris.zone=global variant.opensolaris.zone=global
58dir path=var/svc group=sys opensolaris.zone=global \
59    variant.opensolaris.zone=global
60dir path=var/svc/manifest group=sys opensolaris.zone=global \
61    variant.opensolaris.zone=global
62dir path=var/svc/manifest/system group=sys opensolaris.zone=global \
63    variant.opensolaris.zone=global
64driver name=zcons
65file path=etc/zones/SUNWblank.xml mode=0444
66file path=etc/zones/SUNWdefault.xml mode=0444
67file path=etc/zones/index group=sys opensolaris.zone=global \
68    original_name=SUNWzone:etc/zones/index preserve=true \
69    variant.opensolaris.zone=global
70file path=lib/svc/method/svc-resource-mgmt mode=0555 opensolaris.zone=global \
71    variant.opensolaris.zone=global
72file path=lib/svc/method/svc-zones mode=0555 opensolaris.zone=global \
73    variant.opensolaris.zone=global
74file path=usr/kernel/drv/$(ARCH64)/zcons group=sys
75$(i386_ONLY)file path=usr/kernel/drv/zcons group=sys
76file path=usr/lib/$(ARCH64)/libbrand.so.1
77file path=usr/lib/$(ARCH64)/libzonecfg.so.1
78file path=usr/lib/brand/ipkg/config.xml mode=0444
79file path=usr/lib/brand/ipkg/platform.xml mode=0444
80file path=usr/lib/brand/shared/common.ksh mode=0444
81file path=usr/lib/brand/shared/query mode=0755
82file path=usr/lib/brand/shared/uninstall.ksh mode=0444
83file path=usr/lib/libbrand.so.1
84file path=usr/lib/libzonecfg.so.1
85file path=usr/lib/zones/zoneadmd mode=0555
86file path=usr/sbin/zlogin mode=0555
87file path=usr/sbin/zoneadm mode=0555
88file path=usr/sbin/zonecfg mode=0555
89file path=usr/share/lib/xml/dtd/brand.dtd.1 mode=0644
90file path=usr/share/lib/xml/dtd/zone_platform.dtd.1 mode=0644
91file path=usr/share/lib/xml/dtd/zonecfg.dtd.1
92file path=var/svc/manifest/system/resource-mgmt.xml group=sys mode=0444 \
93    opensolaris.zone=global variant.opensolaris.zone=global
94file path=var/svc/manifest/system/zones.xml group=sys mode=0444 \
95    opensolaris.zone=global variant.opensolaris.zone=global
96legacy pkg=SUNWzoner arch=$(ARCH) category=system \
97    desc="Solaris Zones Configuration Files" \
98    hotline="Please contact your local service provider" \
99    name="Solaris Zones (Root)" vendor="Sun Microsystems, Inc." \
100    version=11.11,REV=2009.11.11
101legacy pkg=SUNWzoneu arch=$(ARCH) category=system \
102    desc="Solaris Zones Configuration and Administration" \
103    hotline="Please contact your local service provider" \
104    name="Solaris Zones (Usr)" vendor="Sun Microsystems, Inc." \
105    version=11.11,REV=2009.11.11
106license cr_Sun license=cr_Sun
107license lic_CDDL license=lic_CDDL
108link path=usr/bin/zonename target=../../sbin/zonename
109