xref: /titanic_41/usr/src/pkg/manifests/system-zones.mf (revision 7c45eec5760d4195b6b85770e7ac51c380adfb8a)
1#
2# CDDL HEADER START
3#
4# The contents of this file are subject to the terms of the
5# Common Development and Distribution License (the "License").
6# You may not use this file except in compliance with the License.
7#
8# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
9# or http://www.opensolaris.org/os/licensing.
10# See the License for the specific language governing permissions
11# and limitations under the License.
12#
13# When distributing Covered Code, include this CDDL HEADER in each
14# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
15# If applicable, add the following below this CDDL HEADER, with the
16# fields enclosed by brackets "[]" replaced with your own identifying
17# information: Portions Copyright [yyyy] [name of copyright owner]
18#
19# CDDL HEADER END
20#
21
22#
23# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
24#
25
26set name=pkg.fmri value=pkg:/system/zones@$(PKGVERS)
27set name=pkg.description \
28    value="Solaris Zones Configuration and Administration"
29set name=pkg.summary value="Solaris Zones"
30set name=info.classification value=org.opensolaris.category.2008:System/Core
31set name=variant.arch value=$(ARCH)
32dir path=etc group=sys variant.opensolaris.zone=global
33dir path=etc/brand group=sys variant.opensolaris.zone=global
34dir path=etc/zones group=sys variant.opensolaris.zone=global
35dir path=lib variant.opensolaris.zone=global
36dir path=lib/svc variant.opensolaris.zone=global
37dir path=lib/svc/manifest group=sys variant.opensolaris.zone=global
38dir path=lib/svc/manifest/system group=sys variant.opensolaris.zone=global
39dir path=lib/svc/method variant.opensolaris.zone=global
40dir path=usr group=sys
41dir path=usr/bin
42dir path=usr/kernel group=sys
43dir path=usr/kernel/drv group=sys
44dir path=usr/kernel/drv/$(ARCH64) group=sys
45dir path=usr/lib
46dir path=usr/lib/$(ARCH64)
47dir path=usr/lib/brand
48dir path=usr/lib/brand/ipkg group=bin
49dir path=usr/lib/brand/shared group=sys
50dir path=usr/lib/zones
51dir path=usr/sbin
52dir path=usr/share
53dir path=usr/share/lib
54dir path=usr/share/lib/xml group=sys
55dir path=usr/share/lib/xml/dtd group=sys
56dir path=usr/share/man
57dir path=usr/share/man/man1
58dir path=usr/share/man/man1m
59dir path=usr/share/man/man5
60dir path=usr/share/man/man7d
61driver name=zcons
62file path=etc/zones/SUNWblank.xml mode=0444 variant.opensolaris.zone=global
63file path=etc/zones/SUNWdefault.xml mode=0444 variant.opensolaris.zone=global
64file path=etc/zones/index group=sys original_name=SUNWzone:etc/zones/index \
65    preserve=true variant.opensolaris.zone=global
66file path=lib/svc/manifest/system/resource-mgmt.xml group=sys mode=0444 \
67    variant.opensolaris.zone=global
68file path=lib/svc/manifest/system/zones.xml group=sys mode=0444 \
69    variant.opensolaris.zone=global
70file path=lib/svc/manifest/system/zonestat.xml group=sys mode=0444 \
71    variant.opensolaris.zone=global
72file path=lib/svc/method/svc-resource-mgmt mode=0555 \
73    variant.opensolaris.zone=global
74file path=lib/svc/method/svc-zones mode=0555 variant.opensolaris.zone=global
75file path=lib/svc/method/svc-zonestat mode=0555 \
76    variant.opensolaris.zone=global
77file path=usr/bin/zonestat mode=0555
78file path=usr/kernel/drv/$(ARCH64)/zcons group=sys
79$(i386_ONLY)file path=usr/kernel/drv/zcons group=sys
80file path=usr/lib/$(ARCH64)/libbrand.so.1
81file path=usr/lib/$(ARCH64)/libzonecfg.so.1
82file path=usr/lib/$(ARCH64)/libzonestat.so.1
83file path=usr/lib/brand/ipkg/config.xml mode=0444
84file path=usr/lib/brand/ipkg/platform.xml mode=0444
85file path=usr/lib/brand/shared/common.ksh mode=0444
86file path=usr/lib/brand/shared/query mode=0755
87file path=usr/lib/brand/shared/uninstall.ksh mode=0444
88file path=usr/lib/libbrand.so.1
89file path=usr/lib/libzonecfg.so.1
90file path=usr/lib/libzonestat.so.1
91file path=usr/lib/zones/zoneadmd mode=0555
92file path=usr/lib/zones/zonestatd mode=0555 variant.opensolaris.zone=global
93file path=usr/sbin/zlogin mode=0555
94file path=usr/sbin/zoneadm mode=0555
95file path=usr/sbin/zonecfg mode=0555
96file path=usr/share/lib/xml/dtd/brand.dtd.1 mode=0644
97file path=usr/share/lib/xml/dtd/zone_platform.dtd.1 mode=0644
98file path=usr/share/lib/xml/dtd/zonecfg.dtd.1
99file path=usr/share/man/man1/zlogin.1
100file path=usr/share/man/man1m/zoneadm.1m
101file path=usr/share/man/man1m/zoneadmd.1m
102file path=usr/share/man/man1m/zonecfg.1m
103file path=usr/share/man/man5/brands.5
104file path=usr/share/man/man5/zones.5
105file path=usr/share/man/man7d/zcons.7d
106legacy pkg=SUNWzoner desc="Solaris Zones Configuration Files" \
107    name="Solaris Zones (Root)"
108legacy pkg=SUNWzoneu desc="Solaris Zones Configuration and Administration" \
109    name="Solaris Zones (Usr)"
110license cr_Sun license=cr_Sun
111license lic_CDDL license=lic_CDDL
112link path=usr/bin/zonename target=../../sbin/zonename
113