xref: /illumos-gate/usr/src/cmd/cmd-inet/sbin/dhcpagent/dhcpagent.dfl (revision e8d3efa1c56e5f2b5368600a2baeb7b1d54a07f8)
1#
2# CDDL HEADER START
3#
4# The contents of this file are subject to the terms of the
5# Common Development and Distribution License (the "License").
6# You may not use this file except in compliance with the License.
7#
8# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
9# or http://www.opensolaris.org/os/licensing.
10# See the License for the specific language governing permissions
11# and limitations under the License.
12#
13# When distributing Covered Code, include this CDDL HEADER in each
14# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
15# If applicable, add the following below this CDDL HEADER, with the
16# fields enclosed by brackets "[]" replaced with your own identifying
17# information: Portions Copyright [yyyy] [name of copyright owner]
18#
19# CDDL HEADER END
20#
21
22#
23# Copyright 2009 Sun Microsystems, Inc.  All rights reserved.
24# Use is subject to license terms.
25# Copyright (c) 2016-2017, Chris Fraire <cfraire@me.com>.
26# Copyright 2019 Joshua M. Clulow <josh@sysmgr.org>
27# Copyright 2026 Oxide Computer Company
28#
29
30#
31# This file contains tunable parameters for dhcpagent(8).
32#
33
34# All parameters can be tuned for a specific interface by prepending
35# the interface name to the parameter name.  For example, to make
36# VERIFIED_LEASE_ONLY happen on all interfaces except hme0, specify:
37#
38# hme0.VERIFIED_LEASE_ONLY=no
39# VERIFIED_LEASE_ONLY=yes
40#
41# An interface name alone specifies IPv4 DHCP.  For DHCPv6, append ".v6".
42# Some examples:
43#
44# hme0.VERIFIED_LEASE_ONLY=no		specify hme0 v4 behavior
45# hme0.v6.VERIFIED_LEASE_ONLY=no	specify hme0 v6 behavior
46# VERIFIED_LEASE_ONLY=no		match all v4 interfaces
47# .v6.VERIFIED_LEASE_ONLY=no		match all v6 interfaces
48
49# By default, when the DHCP agent is sent a SIGTERM (typically when
50# the system is shut down), all managed addresses are dropped rather
51# than released.  Dropping an address does not notify the DHCP server
52# that the address is no longer in use, leaving it possibly available
53# for subsequent use by the same client.  If DHCP is later restarted
54# on the interface, the client will ask the server if it can continue
55# to use the address.  If the server either grants the request, or
56# does not answer (and the lease has not yet expired), then the client
57# will use the original address.
58#
59# Similarly, when the system is suspended and then woken up or when
60# the link status transitions from down to up, DHCP will ask the server
61# to continue to use the managed address, in case the lease has changed.
62#
63# By uncommenting the following parameter-value pairs, all managed
64# addresses are released on SIGTERM instead, and any that may have been
65# saved but cannot be verified will not be used.  When SIGTERM is
66# received, the DHCP server is notified that the address is available
67# for use, and the address will not be saved for a later restart.  If
68# DHCP receives SIGTHAW or a link-up event, DHCP will attempt to verify
69# the previous lease, but if unable to do so, it will not attempt to
70# use that lease.  This behavior is often preferred for roaming systems.
71#
72# VERIFIED_LEASE_ONLY=yes
73# .v6.VERIFIED_LEASE_ONLY=yes
74
75# By default, the DHCP agent waits 3 seconds to collect OFFER
76# responses to a DISCOVER.  If it receives no OFFERs in this time, it
77# then waits for another 3 seconds, and so forth.  To change this
78# behavior, set and uncomment the following parameter-value pair.
79# Note: this does not control the retransmission strategy for
80# DISCOVERs, which is formally specified in RFC 2131.  This parameter
81# is specified in seconds.
82#
83# OFFER_WAIT=
84
85# By default, the DHCP agent does not send out a client identifier
86# (and hence, the chaddr field is used by the DHCP server as the
87# client identifier.)  To make the DHCP agent send a client
88# identifier, set and uncomment the following parameter-value pair.
89# Note that by default this is treated as an NVT ASCII string.  To
90# specify a binary value, prepend "0x" to a sequence of hexadecimal
91# digits (for example, the value 0xAABBCC11 would set the client
92# identifier to the 4-byte binary sequence 0xAA 0xBB 0xCC 0x11).
93#
94# CLIENT_ID=
95
96# By default, for an IPv4 interface that is not in an IP network
97# multipathing (IPMP) group, that is not IP over InfiniBand (IPoIB), and
98# that is not a logical interface, the DHCP agent will forgo sending a
99# client identifier unless CLIENT_ID is defined.
100#
101# To use a system-managed, RFC 3315-style (i.e., DHCPv6-style) binding
102# identifier as documented in RFC 4361, "Node-specific Client Identifiers
103# for DHCPv4," for all IPv4 interfaces (unless CLIENT_ID is defined),
104# uncomment the following line.
105#
106# V4_DEFAULT_IAID_DUID=yes
107
108# By default, the DHCP agent will try to request the Fully Qualified Domain
109# Name (FQDN) currently associated with the interface performing DHCP.  The
110# hostname is defined by using the -h,--reqhost option of ipadm(8) or the
111# ncu ip-reqhost property of nwamcfg(8) or by flagging the interface as
112# primary so that nodename(5) is used as the hostname.
113#
114# A defined hostname will be used as the FQDN if it is "rooted" (i.e., if
115# it ends with a '.') or if it consists of at least three DNS labels (e.g.,
116# srv.example.com).  If the hostname is not an FQDN, then DNS_DOMAINNAME
117# will be appended if defined or ADOPT_DOMAINNAME discernment will be used
118# if active.  If no FQDN can be determined, the option will not be used.
119#
120# If this REQUEST_FQDN option is enabled, an FQDN will be sent in messages
121# to the DHCP server along with RFC 4702 options to request that a
122# collaborating DNS server perform DNS updates for A and PTR resource
123# records.  To prevent sending FQDN and DNS options, uncomment the line
124# below.
125#
126# If an FQDN is sent, REQUEST_HOSTNAME processing will not be done, per RFC
127# 4702 (3.1):  "clients that send the Client FQDN option in their messages
128# MUST NOT also send the Host Name."
129#
130# REQUEST_FQDN=no
131
132# By default, the DHCP agent will not attempt to construct an FQDN from a
133# PQDN specified by the -h,--reqhost option of ipadm(8), by the ncu
134# ip-reqhost property of nwamcfg(8), or by nodename(5).  Set and
135# uncomment the following parameter to indicate a domain name to be used by
136# the DHCP agent to construct if necessary an FQDN.
137#
138# DNS_DOMAINNAME=
139
140# By default, the DHCP agent will not attempt to use a domain name returned
141# by the DHCP server or the domain in resolv.conf(5) to construct an FQDN
142# from a PQDN specified by the -h,--reqhost option of ipadm(8), by the ncu
143# ip-reqhost property of nwamcfg(8), or by nodename(5).  Set and uncomment
144# the following parameter to indicate that a returned DHCPv4 DNSdmain or the
145# domain from resolv.conf(5) should be adopted by the DHCP agent to
146# construct if necessary an FQDN.
147#
148# ADOPT_DOMAINNAME=yes
149
150# By default, the DHCP agent will try to request the hostname currently
151# associated with the interface performing DHCP.  If this option is
152# enabled, the agent will attempt to use an -h,--reqhost option saved with
153# ipadm(8) or an ncu ip-reqhost property set with nwamcfg(8); or else
154# attempt to find a host name in /etc/hostname.<if>, which must contain a
155# line of the form
156#
157#	inet name
158#
159# where "name" is a single RFC 1101-compliant token; or else use
160# nodename(5) for a DHCP interface flagged as primary.  If found in any of
161# these configurations, the token will be used to request that host name
162# from the DHCP server.  To prevent this, uncomment the following line.
163#
164# REQUEST_HOSTNAME=no
165
166# By default, the DHCP agent will set the MTU of the link if the MTU option
167# (26) is provided by the server.  To prevent this, uncomment the following
168# line.
169#
170# SET_MTU=no
171
172# By default, the DHCP agent will manage the lifecycle of additional routes
173# received from the server in the Classless Routes option (121).  To prevent
174# this, uncomment the following line.
175#
176# CLASSLESS_ROUTES=no
177
178# By default, a parameter request list requesting a subnet mask (1), router
179# (3), DNS server (6), hostname (12), DNS domain (15), MTU (26), broadcast
180# address (28), encapsulated vendor options (43), and classless routes (121),
181# is sent to the DHCP server when the DHCP agent sends requests.  However, if
182# desired, this can be changed by altering the following parameter-value pair.
183# The numbers correspond to the values defined in the IANA
184# bootp-dhcp-parameters registry at the time of this writing.  Site and
185# standard option names from /etc/dhcp/inittab are also accepted.
186#
187# Note that RFC 3442 requires that the classless routes option (121) must
188# appear prior to the router option (3) in this list if both are present, but
189# the list is not automatically sorted in order to give the operator more
190# control.
191#
192PARAM_REQUEST_LIST=1,121,3,6,12,15,26,28,43
193
194# The default DHCPv6 parameter request list has preference (7), unicast (12),
195# DNS addresses (23), DNS search list (24), NIS addresses (27), and
196# NIS domain (29).  This may be changed by altering the following parameter-
197# value pair.  The numbers correspond to the values defined in the IANA
198# dhcpv6-parameters registry at the time of this writing.  Site and standard
199# option names from /etc/dhcp/inittab6 are also accepted.
200.v6.PARAM_REQUEST_LIST=7,12,23,24,27,29
201
202# The parameter ignore list allows you to instruct the DHCP client to discard
203# optional parameters received from the DHCP server.  The format is the same
204# as the request list above.  When discarded, a parameter will not be acted
205# on by the DHCP client or returned to users via the dhcpinfo(1) command.
206PARAM_IGNORE_LIST=
207.v6.PARAM_IGNORE_LIST=
208