1 /*- 2 * SPDX-License-Identifier: BSD-3-Clause 3 * 4 * Copyright (c) 1982, 1986, 1990, 1993 5 * The Regents of the University of California. All rights reserved. 6 * 7 * Redistribution and use in source and binary forms, with or without 8 * modification, are permitted provided that the following conditions 9 * are met: 10 * 1. Redistributions of source code must retain the above copyright 11 * notice, this list of conditions and the following disclaimer. 12 * 2. Redistributions in binary form must reproduce the above copyright 13 * notice, this list of conditions and the following disclaimer in the 14 * documentation and/or other materials provided with the distribution. 15 * 3. Neither the name of the University nor the names of its contributors 16 * may be used to endorse or promote products derived from this software 17 * without specific prior written permission. 18 * 19 * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND 20 * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 21 * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE 22 * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE 23 * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL 24 * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS 25 * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) 26 * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 27 * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY 28 * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF 29 * SUCH DAMAGE. 30 */ 31 32 #ifndef _NETINET_IN_H_ 33 #define _NETINET_IN_H_ 34 35 #include <sys/cdefs.h> 36 #include <sys/_types.h> 37 #include <machine/endian.h> 38 39 /* Protocols common to RFC 1700, POSIX, and X/Open. */ 40 #define IPPROTO_IP 0 /* dummy for IP */ 41 #define IPPROTO_ICMP 1 /* control message protocol */ 42 #define IPPROTO_TCP 6 /* tcp */ 43 #define IPPROTO_UDP 17 /* user datagram protocol */ 44 45 #define INADDR_ANY ((in_addr_t)0x00000000) 46 #define INADDR_BROADCAST ((in_addr_t)0xffffffff) /* must be masked */ 47 48 #ifndef _UINT8_T_DECLARED 49 typedef __uint8_t uint8_t; 50 #define _UINT8_T_DECLARED 51 #endif 52 53 #ifndef _UINT16_T_DECLARED 54 typedef __uint16_t uint16_t; 55 #define _UINT16_T_DECLARED 56 #endif 57 58 #ifndef _UINT32_T_DECLARED 59 typedef __uint32_t uint32_t; 60 #define _UINT32_T_DECLARED 61 #endif 62 63 #ifndef _IN_ADDR_T_DECLARED 64 typedef uint32_t in_addr_t; 65 #define _IN_ADDR_T_DECLARED 66 #endif 67 68 #ifndef _IN_PORT_T_DECLARED 69 typedef uint16_t in_port_t; 70 #define _IN_PORT_T_DECLARED 71 #endif 72 73 #ifndef _SA_FAMILY_T_DECLARED 74 typedef __sa_family_t sa_family_t; 75 #define _SA_FAMILY_T_DECLARED 76 #endif 77 78 /* Internet address (a structure for historical reasons). */ 79 #ifndef _STRUCT_IN_ADDR_DECLARED 80 struct in_addr { 81 in_addr_t s_addr; 82 }; 83 #define _STRUCT_IN_ADDR_DECLARED 84 #endif 85 86 #ifndef _SOCKLEN_T_DECLARED 87 typedef __socklen_t socklen_t; 88 #define _SOCKLEN_T_DECLARED 89 #endif 90 91 #include <sys/_sockaddr_storage.h> 92 93 /* Socket address, internet style. */ 94 struct sockaddr_in { 95 uint8_t sin_len; 96 sa_family_t sin_family; 97 in_port_t sin_port; 98 struct in_addr sin_addr; 99 char sin_zero[8]; 100 }; 101 102 #if !defined(_KERNEL) && __POSIX_VISIBLE >= 200112 103 104 #ifndef _BYTEORDER_PROTOTYPED 105 #define _BYTEORDER_PROTOTYPED 106 __BEGIN_DECLS 107 uint32_t htonl(uint32_t); 108 uint16_t htons(uint16_t); 109 uint32_t ntohl(uint32_t); 110 uint16_t ntohs(uint16_t); 111 __END_DECLS 112 #endif 113 114 #ifndef _BYTEORDER_FUNC_DEFINED 115 #define _BYTEORDER_FUNC_DEFINED 116 #define htonl(x) __htonl(x) 117 #define htons(x) __htons(x) 118 #define ntohl(x) __ntohl(x) 119 #define ntohs(x) __ntohs(x) 120 #endif 121 122 #endif /* !_KERNEL && __POSIX_VISIBLE >= 200112 */ 123 124 #if __POSIX_VISIBLE >= 200112 125 #define IPPROTO_IPV6 41 /* IP6 header */ 126 #define IPPROTO_RAW 255 /* raw IP packet */ 127 #define INET_ADDRSTRLEN 16 128 #endif 129 130 #if __BSD_VISIBLE 131 /* 132 * Constants and structures defined by the internet system, 133 * Per RFC 790, September 1981, and numerous additions. 134 */ 135 136 /* 137 * Protocols (RFC 1700) 138 */ 139 #define IPPROTO_HOPOPTS 0 /* IP6 hop-by-hop options */ 140 #define IPPROTO_IGMP 2 /* group mgmt protocol */ 141 #define IPPROTO_GGP 3 /* gateway^2 (deprecated) */ 142 #define IPPROTO_IPV4 4 /* IPv4 encapsulation */ 143 #define IPPROTO_IPIP IPPROTO_IPV4 /* for compatibility */ 144 #define IPPROTO_ST 7 /* Stream protocol II */ 145 #define IPPROTO_EGP 8 /* exterior gateway protocol */ 146 #define IPPROTO_PIGP 9 /* private interior gateway */ 147 #define IPPROTO_RCCMON 10 /* BBN RCC Monitoring */ 148 #define IPPROTO_NVPII 11 /* network voice protocol*/ 149 #define IPPROTO_PUP 12 /* pup */ 150 #define IPPROTO_ARGUS 13 /* Argus */ 151 #define IPPROTO_EMCON 14 /* EMCON */ 152 #define IPPROTO_XNET 15 /* Cross Net Debugger */ 153 #define IPPROTO_CHAOS 16 /* Chaos*/ 154 #define IPPROTO_MUX 18 /* Multiplexing */ 155 #define IPPROTO_MEAS 19 /* DCN Measurement Subsystems */ 156 #define IPPROTO_HMP 20 /* Host Monitoring */ 157 #define IPPROTO_PRM 21 /* Packet Radio Measurement */ 158 #define IPPROTO_IDP 22 /* xns idp */ 159 #define IPPROTO_TRUNK1 23 /* Trunk-1 */ 160 #define IPPROTO_TRUNK2 24 /* Trunk-2 */ 161 #define IPPROTO_LEAF1 25 /* Leaf-1 */ 162 #define IPPROTO_LEAF2 26 /* Leaf-2 */ 163 #define IPPROTO_RDP 27 /* Reliable Data */ 164 #define IPPROTO_IRTP 28 /* Reliable Transaction */ 165 #define IPPROTO_TP 29 /* tp-4 w/ class negotiation */ 166 #define IPPROTO_BLT 30 /* Bulk Data Transfer */ 167 #define IPPROTO_NSP 31 /* Network Services */ 168 #define IPPROTO_INP 32 /* Merit Internodal */ 169 #define IPPROTO_DCCP 33 /* Datagram Congestion Control Protocol */ 170 #define IPPROTO_3PC 34 /* Third Party Connect */ 171 #define IPPROTO_IDPR 35 /* InterDomain Policy Routing */ 172 #define IPPROTO_XTP 36 /* XTP */ 173 #define IPPROTO_DDP 37 /* Datagram Delivery */ 174 #define IPPROTO_CMTP 38 /* Control Message Transport */ 175 #define IPPROTO_TPXX 39 /* TP++ Transport */ 176 #define IPPROTO_IL 40 /* IL transport protocol */ 177 #define IPPROTO_SDRP 42 /* Source Demand Routing */ 178 #define IPPROTO_ROUTING 43 /* IP6 routing header */ 179 #define IPPROTO_FRAGMENT 44 /* IP6 fragmentation header */ 180 #define IPPROTO_IDRP 45 /* InterDomain Routing*/ 181 #define IPPROTO_RSVP 46 /* resource reservation */ 182 #define IPPROTO_GRE 47 /* General Routing Encap. */ 183 #define IPPROTO_MHRP 48 /* Mobile Host Routing */ 184 #define IPPROTO_BHA 49 /* BHA */ 185 #define IPPROTO_ESP 50 /* IP6 Encap Sec. Payload */ 186 #define IPPROTO_AH 51 /* IP6 Auth Header */ 187 #define IPPROTO_INLSP 52 /* Integ. Net Layer Security */ 188 #define IPPROTO_SWIPE 53 /* IP with encryption */ 189 #define IPPROTO_NHRP 54 /* Next Hop Resolution */ 190 #define IPPROTO_MOBILE 55 /* IP Mobility */ 191 #define IPPROTO_TLSP 56 /* Transport Layer Security */ 192 #define IPPROTO_SKIP 57 /* SKIP */ 193 #define IPPROTO_ICMPV6 58 /* ICMP6 */ 194 #define IPPROTO_NONE 59 /* IP6 no next header */ 195 #define IPPROTO_DSTOPTS 60 /* IP6 destination option */ 196 #define IPPROTO_AHIP 61 /* any host internal protocol */ 197 #define IPPROTO_CFTP 62 /* CFTP */ 198 #define IPPROTO_HELLO 63 /* "hello" routing protocol */ 199 #define IPPROTO_SATEXPAK 64 /* SATNET/Backroom EXPAK */ 200 #define IPPROTO_KRYPTOLAN 65 /* Kryptolan */ 201 #define IPPROTO_RVD 66 /* Remote Virtual Disk */ 202 #define IPPROTO_IPPC 67 /* Pluribus Packet Core */ 203 #define IPPROTO_ADFS 68 /* Any distributed FS */ 204 #define IPPROTO_SATMON 69 /* Satnet Monitoring */ 205 #define IPPROTO_VISA 70 /* VISA Protocol */ 206 #define IPPROTO_IPCV 71 /* Packet Core Utility */ 207 #define IPPROTO_CPNX 72 /* Comp. Prot. Net. Executive */ 208 #define IPPROTO_CPHB 73 /* Comp. Prot. HeartBeat */ 209 #define IPPROTO_WSN 74 /* Wang Span Network */ 210 #define IPPROTO_PVP 75 /* Packet Video Protocol */ 211 #define IPPROTO_BRSATMON 76 /* BackRoom SATNET Monitoring */ 212 #define IPPROTO_ND 77 /* Sun net disk proto (temp.) */ 213 #define IPPROTO_WBMON 78 /* WIDEBAND Monitoring */ 214 #define IPPROTO_WBEXPAK 79 /* WIDEBAND EXPAK */ 215 #define IPPROTO_EON 80 /* ISO cnlp */ 216 #define IPPROTO_VMTP 81 /* VMTP */ 217 #define IPPROTO_SVMTP 82 /* Secure VMTP */ 218 #define IPPROTO_VINES 83 /* Banyon VINES */ 219 #define IPPROTO_TTP 84 /* TTP */ 220 #define IPPROTO_IGP 85 /* NSFNET-IGP */ 221 #define IPPROTO_DGP 86 /* dissimilar gateway prot. */ 222 #define IPPROTO_TCF 87 /* TCF */ 223 #define IPPROTO_IGRP 88 /* Cisco/GXS IGRP */ 224 #define IPPROTO_OSPFIGP 89 /* OSPFIGP */ 225 #define IPPROTO_SRPC 90 /* Strite RPC protocol */ 226 #define IPPROTO_LARP 91 /* Locus Address Resoloution */ 227 #define IPPROTO_MTP 92 /* Multicast Transport */ 228 #define IPPROTO_AX25 93 /* AX.25 Frames */ 229 #define IPPROTO_IPEIP 94 /* IP encapsulated in IP */ 230 #define IPPROTO_MICP 95 /* Mobile Int.ing control */ 231 #define IPPROTO_SCCSP 96 /* Semaphore Comm. security */ 232 #define IPPROTO_ETHERIP 97 /* Ethernet IP encapsulation */ 233 #define IPPROTO_ENCAP 98 /* encapsulation header */ 234 #define IPPROTO_APES 99 /* any private encr. scheme */ 235 #define IPPROTO_GMTP 100 /* GMTP*/ 236 #define IPPROTO_IPCOMP 108 /* payload compression (IPComp) */ 237 #define IPPROTO_SCTP 132 /* SCTP */ 238 #define IPPROTO_MH 135 /* IPv6 Mobility Header */ 239 #define IPPROTO_UDPLITE 136 /* UDP-Lite */ 240 #define IPPROTO_HIP 139 /* IP6 Host Identity Protocol */ 241 #define IPPROTO_SHIM6 140 /* IP6 Shim6 Protocol */ 242 /* 101-254: Partly Unassigned */ 243 #define IPPROTO_PIM 103 /* Protocol Independent Mcast */ 244 #define IPPROTO_CARP 112 /* CARP */ 245 #define IPPROTO_PGM 113 /* PGM */ 246 #define IPPROTO_MPLS 137 /* MPLS-in-IP */ 247 #define IPPROTO_PFSYNC 240 /* PFSYNC */ 248 #define IPPROTO_RESERVED_253 253 /* Reserved */ 249 #define IPPROTO_RESERVED_254 254 /* Reserved */ 250 /* 255: Reserved */ 251 #define IPPROTO_MAX 256 252 253 /* last return value of *_input(), meaning "all job for this pkt is done". */ 254 #define IPPROTO_DONE 257 255 256 /* Only used internally, so can be outside the range of valid IP protocols. */ 257 #define IPPROTO_SEND 259 /* SeND pseudo-protocol */ 258 259 /* 260 * Defined to avoid confusion. The master value is defined by 261 * PROTO_SPACER in sys/protosw.h. 262 */ 263 #define IPPROTO_SPACER 32767 /* spacer for loadable protos */ 264 265 /* 266 * Local port number conventions: 267 * 268 * When a user does a bind(2) or connect(2) with a port number of zero, 269 * a non-conflicting local port address is chosen. 270 * The default range is IPPORT_HIFIRSTAUTO through 271 * IPPORT_HILASTAUTO, although that is settable by sysctl. 272 * 273 * A user may set the IPPROTO_IP option IP_PORTRANGE to change this 274 * default assignment range. 275 * 276 * The value IP_PORTRANGE_DEFAULT causes the default behavior. 277 * 278 * The value IP_PORTRANGE_HIGH changes the range of candidate port numbers 279 * into the "high" range. These are reserved for client outbound connections 280 * which do not want to be filtered by any firewalls. 281 * 282 * The value IP_PORTRANGE_LOW changes the range to the "low" are 283 * that is (by convention) restricted to privileged processes. This 284 * convention is based on "vouchsafe" principles only. It is only secure 285 * if you trust the remote host to restrict these ports. 286 * 287 * The default range of ports and the high range can be changed by 288 * sysctl(3). (net.inet.ip.portrange.{hi,low,}{first,last}) 289 * 290 * Changing those values has bad security implications if you are 291 * using a stateless firewall that is allowing packets outside of that 292 * range in order to allow transparent outgoing connections. 293 * 294 * Such a firewall configuration will generally depend on the use of these 295 * default values. If you change them, you may find your Security 296 * Administrator looking for you with a heavy object. 297 * 298 * For a slightly more orthodox text view on this: 299 * 300 * ftp://ftp.isi.edu/in-notes/iana/assignments/port-numbers 301 * 302 * port numbers are divided into three ranges: 303 * 304 * 0 - 1023 Well Known Ports 305 * 1024 - 49151 Registered Ports 306 * 49152 - 65535 Dynamic and/or Private Ports 307 * 308 */ 309 310 /* 311 * Ports < IPPORT_RESERVED are reserved for 312 * privileged processes (e.g. root). (IP_PORTRANGE_LOW) 313 */ 314 #define IPPORT_RESERVED 1024 315 316 /* 317 * Default local port range, used by IP_PORTRANGE_DEFAULT 318 */ 319 #define IPPORT_EPHEMERALFIRST 10000 320 #define IPPORT_EPHEMERALLAST 65535 321 322 /* 323 * Dynamic port range, used by IP_PORTRANGE_HIGH. 324 */ 325 #define IPPORT_HIFIRSTAUTO 49152 326 #define IPPORT_HILASTAUTO 65535 327 328 /* 329 * Scanning for a free reserved port return a value below IPPORT_RESERVED, 330 * but higher than IPPORT_RESERVEDSTART. Traditionally the start value was 331 * 512, but that conflicts with some well-known-services that firewalls may 332 * have a fit if we use. 333 */ 334 #define IPPORT_RESERVEDSTART 600 335 336 #define IPPORT_MAX 65535 337 338 /* 339 * Historical definitions of bits in internet address integers 340 * (pre-CIDR). Class A/B/C are long obsolete, and now deprecated. 341 * Hide these definitions from the kernel unless IN_HISTORICAL_NETS 342 * is defined. Provide the historical definitions to user level for now. 343 */ 344 #ifndef _KERNEL 345 #define IN_HISTORICAL_NETS 346 #endif 347 #ifdef IN_HISTORICAL_NETS 348 #define IN_CLASSA(i) (((in_addr_t)(i) & 0x80000000) == 0) 349 #define IN_CLASSA_NET 0xff000000 350 #define IN_CLASSA_NSHIFT 24 351 #define IN_CLASSA_HOST 0x00ffffff 352 #define IN_CLASSA_MAX 128 353 354 #define IN_CLASSB(i) (((in_addr_t)(i) & 0xc0000000) == 0x80000000) 355 #define IN_CLASSB_NET 0xffff0000 356 #define IN_CLASSB_NSHIFT 16 357 #define IN_CLASSB_HOST 0x0000ffff 358 #define IN_CLASSB_MAX 65536 359 360 #define IN_CLASSC(i) (((in_addr_t)(i) & 0xe0000000) == 0xc0000000) 361 #define IN_CLASSC_NET 0xffffff00 362 #define IN_CLASSC_NSHIFT 8 363 #define IN_CLASSC_HOST 0x000000ff 364 #endif /* IN_HISTORICAL_NETS */ 365 366 #define IN_NETMASK_DEFAULT 0xffffff00 /* mask when forced to guess */ 367 368 #define IN_MULTICAST(i) (((in_addr_t)(i) & 0xf0000000) == 0xe0000000) 369 #ifdef IN_HISTORICAL_NETS 370 #define IN_CLASSD(i) IN_MULTICAST(i) 371 #define IN_CLASSD_NET 0xf0000000 /* These ones aren't really */ 372 #define IN_CLASSD_NSHIFT 28 /* net and host fields, but */ 373 #define IN_CLASSD_HOST 0x0fffffff /* routing needn't know. */ 374 #endif /* IN_HISTORICAL_NETS */ 375 376 #define IN_EXPERIMENTAL(i) (((in_addr_t)(i) & 0xf0000000) == 0xf0000000) 377 #define IN_BADCLASS(i) (((in_addr_t)(i) & 0xf0000000) == 0xf0000000) 378 379 #define IN_LINKLOCAL(i) (((in_addr_t)(i) & 0xffff0000) == 0xa9fe0000) 380 #ifdef _KERNEL 381 #define IN_LOOPBACK(i) \ 382 (((in_addr_t)(i) & V_in_loopback_mask) == 0x7f000000) 383 #define IN_LOOPBACK_MASK_DFLT 0xff000000 384 #else 385 #define IN_LOOPBACK(i) (((in_addr_t)(i) & 0xff000000) == 0x7f000000) 386 #endif 387 #define IN_ZERONET(i) (((in_addr_t)(i) & 0xff000000) == 0) 388 389 #define IN_PRIVATE(i) ((((in_addr_t)(i) & 0xff000000) == 0x0a000000) || \ 390 (((in_addr_t)(i) & 0xfff00000) == 0xac100000) || \ 391 (((in_addr_t)(i) & 0xffff0000) == 0xc0a80000)) 392 393 #define IN_LOCAL_GROUP(i) (((in_addr_t)(i) & 0xffffff00) == 0xe0000000) 394 395 #define IN_ANY_LOCAL(i) (IN_LINKLOCAL(i) || IN_LOCAL_GROUP(i)) 396 397 #define INADDR_LOOPBACK ((in_addr_t)0x7f000001) 398 #ifndef _KERNEL 399 #define INADDR_NONE ((in_addr_t)0xffffffff) /* -1 return */ 400 #endif 401 402 #define INADDR_UNSPEC_GROUP ((in_addr_t)0xe0000000) /* 224.0.0.0 */ 403 #define INADDR_ALLHOSTS_GROUP ((in_addr_t)0xe0000001) /* 224.0.0.1 */ 404 #define INADDR_ALLRTRS_GROUP ((in_addr_t)0xe0000002) /* 224.0.0.2 */ 405 #define INADDR_ALLRPTS_GROUP ((in_addr_t)0xe0000016) /* 224.0.0.22, IGMPv3 */ 406 #define INADDR_CARP_GROUP ((in_addr_t)0xe0000012) /* 224.0.0.18 */ 407 #define INADDR_PFSYNC_GROUP ((in_addr_t)0xe00000f0) /* 224.0.0.240 */ 408 #define INADDR_ALLMDNS_GROUP ((in_addr_t)0xe00000fb) /* 224.0.0.251 */ 409 #define INADDR_MAX_LOCAL_GROUP ((in_addr_t)0xe00000ff) /* 224.0.0.255 */ 410 411 #ifdef IN_HISTORICAL_NETS 412 #define IN_LOOPBACKNET 127 /* official! */ 413 #endif /* IN_HISTORICAL_NETS */ 414 415 #define IN_RFC3021_MASK ((in_addr_t)0xfffffffe) 416 417 #ifdef _KERNEL 418 #include <net/vnet.h> 419 420 VNET_DECLARE(bool, ip_allow_net0); 421 VNET_DECLARE(bool, ip_allow_net240); 422 /* Address space reserved for loopback */ 423 VNET_DECLARE(uint32_t, in_loopback_mask); 424 #define V_ip_allow_net0 VNET(ip_allow_net0) 425 #define V_ip_allow_net240 VNET(ip_allow_net240) 426 #define V_in_loopback_mask VNET(in_loopback_mask) 427 #endif 428 429 /* 430 * Options for use with [gs]etsockopt at the IP level. 431 * First word of comment is data type; bool is stored in int. 432 */ 433 #define IP_OPTIONS 1 /* buf/ip_opts; set/get IP options */ 434 #define IP_HDRINCL 2 /* int; header is included with data */ 435 #define IP_TOS 3 /* int; IP type of service and preced. */ 436 #define IP_TTL 4 /* int; IP time to live */ 437 #define IP_RECVOPTS 5 /* bool; receive all IP opts w/dgram */ 438 #define IP_RECVRETOPTS 6 /* bool; receive IP opts for response */ 439 #define IP_RECVDSTADDR 7 /* bool; receive IP dst addr w/dgram */ 440 #define IP_SENDSRCADDR IP_RECVDSTADDR /* cmsg_type to set src addr */ 441 #define IP_RETOPTS 8 /* ip_opts; set/get IP options */ 442 #define IP_MULTICAST_IF 9 /* struct in_addr *or* struct ip_mreqn; 443 * set/get IP multicast i/f */ 444 #define IP_MULTICAST_TTL 10 /* u_char,u_int; set/get IP multicast ttl */ 445 #define IP_MULTICAST_LOOP 11 /* u_char,u_int; set/get IP multicast loopback */ 446 #define IP_ADD_MEMBERSHIP 12 /* ip_mreq; add an IP group membership */ 447 #define IP_DROP_MEMBERSHIP 13 /* ip_mreq; drop an IP group membership */ 448 #define IP_MULTICAST_VIF 14 /* int; set/get IP mcast virt. iface */ 449 #define IP_RSVP_ON 15 /* int; enable RSVP in kernel */ 450 #define IP_RSVP_OFF 16 /* int; disable RSVP in kernel */ 451 #define IP_RSVP_VIF_ON 17 /* int; set RSVP per-vif socket */ 452 #define IP_RSVP_VIF_OFF 18 /* int; unset RSVP per-vif socket */ 453 #define IP_PORTRANGE 19 /* int; range to choose for unspec port */ 454 #define IP_RECVIF 20 /* bool; receive reception if w/dgram */ 455 /* for IPSEC */ 456 #define IP_IPSEC_POLICY 21 /* int; set/get security policy */ 457 /* unused; was IP_FAITH */ 458 #define IP_ONESBCAST 23 /* bool; send all-ones broadcast */ 459 #define IP_BINDANY 24 /* bool; allow bind to any address */ 460 /* unused; was IP_BIND_MULTI */ 461 /* unused; was IP_RSS_LISTEN_BUCKET */ 462 #define IP_ORIGDSTADDR 27 /* bool; receive IP dst addr/port w/dgram */ 463 #define IP_RECVORIGDSTADDR IP_ORIGDSTADDR 464 465 /* 466 * Options for controlling the firewall and dummynet. 467 * Historical options (from 40 to 64) will eventually be 468 * replaced by only two options, IP_FW3 and IP_DUMMYNET3. 469 */ 470 #define IP_FW_TABLE_ADD 40 /* add entry */ 471 #define IP_FW_TABLE_DEL 41 /* delete entry */ 472 #define IP_FW_TABLE_FLUSH 42 /* flush table */ 473 #define IP_FW_TABLE_GETSIZE 43 /* get table size */ 474 #define IP_FW_TABLE_LIST 44 /* list table contents */ 475 476 #define IP_FW3 48 /* generic ipfw v.3 sockopts */ 477 #define IP_DUMMYNET3 49 /* generic dummynet v.3 sockopts */ 478 479 #define IP_FW_ADD 50 /* add a firewall rule to chain */ 480 #define IP_FW_DEL 51 /* delete a firewall rule from chain */ 481 #define IP_FW_FLUSH 52 /* flush firewall rule chain */ 482 #define IP_FW_ZERO 53 /* clear single/all firewall counter(s) */ 483 #define IP_FW_GET 54 /* get entire firewall rule chain */ 484 #define IP_FW_RESETLOG 55 /* reset logging counters */ 485 486 #define IP_FW_NAT_CFG 56 /* add/config a nat rule */ 487 #define IP_FW_NAT_DEL 57 /* delete a nat rule */ 488 #define IP_FW_NAT_GET_CONFIG 58 /* get configuration of a nat rule */ 489 #define IP_FW_NAT_GET_LOG 59 /* get log of a nat rule */ 490 491 #define IP_DUMMYNET_CONFIGURE 60 /* add/configure a dummynet pipe */ 492 #define IP_DUMMYNET_DEL 61 /* delete a dummynet pipe from chain */ 493 #define IP_DUMMYNET_FLUSH 62 /* flush dummynet */ 494 #define IP_DUMMYNET_GET 64 /* get entire dummynet pipes */ 495 496 #define IP_RECVTTL 65 /* bool; receive IP TTL w/dgram */ 497 #define IP_MINTTL 66 /* int; minimum TTL for packet or drop */ 498 #define IP_DONTFRAG 67 /* int; don't fragment packet */ 499 #define IP_RECVTOS 68 /* bool; receive IP TOS w/dgram */ 500 501 /* IPv4 Source Filter Multicast API [RFC3678] */ 502 #define IP_ADD_SOURCE_MEMBERSHIP 70 /* ip_mreq_source; join a source-specific group */ 503 #define IP_DROP_SOURCE_MEMBERSHIP 71 /* ip_mreq_source; drop a single source */ 504 #define IP_BLOCK_SOURCE 72 /* ip_mreq_source; block a source */ 505 #define IP_UNBLOCK_SOURCE 73 /* ip_mreq_source; unblock a source */ 506 507 /* The following option is private; do not use it from user applications. */ 508 #define IP_MSFILTER 74 /* __msfilterreq; set/get filter list */ 509 510 /* The following option deals with the 802.1Q Ethernet Priority Code Point */ 511 #define IP_VLAN_PCP 75 /* int; set/get PCP used for packet, */ 512 /* -1 use interface default */ 513 514 /* Protocol Independent Multicast API [RFC3678] */ 515 #define MCAST_JOIN_GROUP 80 /* join an any-source group */ 516 #define MCAST_LEAVE_GROUP 81 /* leave all sources for group */ 517 #define MCAST_JOIN_SOURCE_GROUP 82 /* join a source-specific group */ 518 #define MCAST_LEAVE_SOURCE_GROUP 83 /* leave a single source */ 519 #define MCAST_BLOCK_SOURCE 84 /* block a source */ 520 #define MCAST_UNBLOCK_SOURCE 85 /* unblock a source */ 521 522 /* Flow and RSS definitions */ 523 #define IP_FLOWID 90 /* int; get flow id for the given socket/inp */ 524 #define IP_FLOWTYPE 91 /* int; get flow type (M_HASHTYPE) */ 525 #define IP_RSSBUCKETID 92 /* int; get RSS flowid -> bucket mapping */ 526 #define IP_RECVFLOWID 93 /* bool; receive IP flowid/flowtype w/ datagram */ 527 #define IP_RECVRSSBUCKETID 94 /* bool; receive IP RSS bucket id w/ datagram */ 528 529 /* 530 * Defaults and limits for options 531 */ 532 #define IP_DEFAULT_MULTICAST_TTL 1 /* normally limit m'casts to 1 hop */ 533 #define IP_DEFAULT_MULTICAST_LOOP 1 /* normally hear sends if a member */ 534 535 /* 536 * Limit for IPv4 multicast memberships 537 */ 538 #define IP_MAX_MEMBERSHIPS 4095 539 540 /* 541 * Default resource limits for IPv4 multicast source filtering. 542 * These may be modified by sysctl. 543 */ 544 #define IP_MAX_GROUP_SRC_FILTER 512 /* sources per group */ 545 #define IP_MAX_SOCK_SRC_FILTER 128 /* sources per socket/group */ 546 #define IP_MAX_SOCK_MUTE_FILTER 128 /* XXX no longer used */ 547 548 /* 549 * Argument structure for IP_ADD_MEMBERSHIP and IP_DROP_MEMBERSHIP. 550 */ 551 struct ip_mreq { 552 struct in_addr imr_multiaddr; /* IP multicast address of group */ 553 struct in_addr imr_interface; /* local IP address of interface */ 554 }; 555 556 /* 557 * Modified argument structure for IP_MULTICAST_IF, obtained from Linux. 558 * This is used to specify an interface index for multicast sends, as 559 * the IPv4 legacy APIs do not support this (unless IP_SENDIF is available). 560 */ 561 struct ip_mreqn { 562 struct in_addr imr_multiaddr; /* IP multicast address of group */ 563 struct in_addr imr_address; /* local IP address of interface */ 564 int imr_ifindex; /* Interface index; cast to uint32_t */ 565 }; 566 567 /* 568 * Argument structure for IPv4 Multicast Source Filter APIs. [RFC3678] 569 */ 570 struct ip_mreq_source { 571 struct in_addr imr_multiaddr; /* IP multicast address of group */ 572 struct in_addr imr_sourceaddr; /* IP address of source */ 573 struct in_addr imr_interface; /* local IP address of interface */ 574 }; 575 576 /* 577 * Argument structures for Protocol-Independent Multicast Source 578 * Filter APIs. [RFC3678] 579 */ 580 struct group_req { 581 uint32_t gr_interface; /* interface index */ 582 struct sockaddr_storage gr_group; /* group address */ 583 }; 584 585 struct group_source_req { 586 uint32_t gsr_interface; /* interface index */ 587 struct sockaddr_storage gsr_group; /* group address */ 588 struct sockaddr_storage gsr_source; /* source address */ 589 }; 590 591 #ifndef __MSFILTERREQ_DEFINED 592 #define __MSFILTERREQ_DEFINED 593 /* 594 * The following structure is private; do not use it from user applications. 595 * It is used to communicate IP_MSFILTER/IPV6_MSFILTER information between 596 * the RFC 3678 libc functions and the kernel. 597 */ 598 struct __msfilterreq { 599 uint32_t msfr_ifindex; /* interface index */ 600 uint32_t msfr_fmode; /* filter mode for group */ 601 uint32_t msfr_nsrcs; /* # of sources in msfr_srcs */ 602 struct sockaddr_storage msfr_group; /* group address */ 603 struct sockaddr_storage *msfr_srcs; /* pointer to the first member 604 * of a contiguous array of 605 * sources to filter in full. 606 */ 607 }; 608 #endif 609 610 struct sockaddr; 611 612 /* 613 * Advanced (Full-state) APIs [RFC3678] 614 * The RFC specifies uint_t for the 6th argument to [sg]etsourcefilter(). 615 * We use uint32_t here to be consistent. 616 */ 617 int setipv4sourcefilter(int, struct in_addr, struct in_addr, uint32_t, 618 uint32_t, struct in_addr *); 619 int getipv4sourcefilter(int, struct in_addr, struct in_addr, uint32_t *, 620 uint32_t *, struct in_addr *); 621 int setsourcefilter(int, uint32_t, struct sockaddr *, socklen_t, 622 uint32_t, uint32_t, struct sockaddr_storage *); 623 int getsourcefilter(int, uint32_t, struct sockaddr *, socklen_t, 624 uint32_t *, uint32_t *, struct sockaddr_storage *); 625 626 /* 627 * Filter modes; also used to represent per-socket filter mode internally. 628 */ 629 #define MCAST_UNDEFINED 0 /* fmode: not yet defined */ 630 #define MCAST_INCLUDE 1 /* fmode: include these source(s) */ 631 #define MCAST_EXCLUDE 2 /* fmode: exclude these source(s) */ 632 633 /* 634 * Argument for IP_PORTRANGE: 635 * - which range to search when port is unspecified at bind() or connect() 636 */ 637 #define IP_PORTRANGE_DEFAULT 0 /* default range */ 638 #define IP_PORTRANGE_HIGH 1 /* "high" - request firewall bypass */ 639 #define IP_PORTRANGE_LOW 2 /* "low" - vouchsafe security */ 640 641 /* 642 * Identifiers for IP sysctl nodes 643 */ 644 #define IPCTL_FORWARDING 1 /* act as router */ 645 #define IPCTL_SENDREDIRECTS 2 /* may send redirects when forwarding */ 646 #define IPCTL_DEFTTL 3 /* default TTL */ 647 #ifdef notyet 648 #define IPCTL_DEFMTU 4 /* default MTU */ 649 #endif 650 /* IPCTL_RTEXPIRE 5 deprecated */ 651 /* IPCTL_RTMINEXPIRE 6 deprecated */ 652 /* IPCTL_RTMAXCACHE 7 deprecated */ 653 #define IPCTL_SOURCEROUTE 8 /* may perform source routes */ 654 #define IPCTL_DIRECTEDBROADCAST 9 /* may re-broadcast received packets */ 655 #define IPCTL_INTRQMAXLEN 10 /* max length of netisr queue */ 656 #define IPCTL_INTRQDROPS 11 /* number of netisr q drops */ 657 #define IPCTL_STATS 12 /* ipstat structure */ 658 #define IPCTL_ACCEPTSOURCEROUTE 13 /* may accept source routed packets */ 659 #define IPCTL_FASTFORWARDING 14 /* use fast IP forwarding code */ 660 /* 15, unused, was: IPCTL_KEEPFAITH */ 661 #define IPCTL_GIF_TTL 16 /* default TTL for gif encap packet */ 662 #define IPCTL_INTRDQMAXLEN 17 /* max length of direct netisr queue */ 663 #define IPCTL_INTRDQDROPS 18 /* number of direct netisr q drops */ 664 665 #endif /* __BSD_VISIBLE */ 666 667 #ifdef _KERNEL 668 669 struct ifnet; struct mbuf; /* forward declarations for Standard C */ 670 struct in_ifaddr; 671 672 bool in_ifnet_broadcast(struct in_addr, struct ifnet *); 673 bool in_ifaddr_broadcast(struct in_addr, struct in_ifaddr *); 674 bool in_canforward(struct in_addr); 675 bool in_localaddr(struct in_addr); 676 bool in_localip(struct in_addr); 677 bool in_localip_fib(struct in_addr, uint16_t); 678 bool in_ifhasaddr(struct ifnet *, struct in_addr); 679 struct in_ifaddr *in_findlocal(uint32_t, bool); 680 struct in_ifaddr *in_ifprimaryaddr(struct ifnet *); 681 int inet_aton(const char *, struct in_addr *); /* in libkern */ 682 char *inet_ntoa_r(struct in_addr ina, char *buf); /* in libkern */ 683 char *inet_ntop(int, const void *, char *, socklen_t); /* in libkern */ 684 int inet_pton(int af, const char *, void *); /* in libkern */ 685 686 static inline bool 687 in_broadcast(struct in_addr in) 688 { 689 return (in.s_addr == __htonl(INADDR_BROADCAST) || 690 in.s_addr == __htonl(INADDR_ANY)); 691 } 692 693 #define in_hosteq(s, t) ((s).s_addr == (t).s_addr) 694 #define in_nullhost(x) ((x).s_addr == INADDR_ANY) 695 #define in_allhosts(x) ((x).s_addr == htonl(INADDR_ALLHOSTS_GROUP)) 696 697 #define satosin(sa) ((struct sockaddr_in *)(sa)) 698 #define sintosa(sin) ((struct sockaddr *)(sin)) 699 #define ifatoia(ifa) ((struct in_ifaddr *)(ifa)) 700 #endif /* _KERNEL */ 701 702 /* INET6 stuff */ 703 #if __POSIX_VISIBLE >= 200112 704 #define __KAME_NETINET_IN_H_INCLUDED_ 705 #include <netinet6/in6.h> 706 #undef __KAME_NETINET_IN_H_INCLUDED_ 707 #endif 708 709 #endif /* !_NETINET_IN_H_*/ 710