Home
last modified time | relevance | path

Searched refs:CMP (Results 1 – 25 of 133) sorted by relevance

123456

/freebsd/lib/libc/stdlib/
H A Dqsort.c71 #define CMP(t, x, y) (cmp((x), (y), (t))) macro
73 #define CMP(t, x, y) (cmp((t), (x), (y))) macro
75 #define CMP(t, x, y) (cmp((x), (y), (t))) macro
77 #define CMP(t, x, y) (cmp((x), (y))) macro
87 return CMP(thunk, a, b) < 0 ? in med3()
88 (CMP(thunk, b, c) < 0 ? b : (CMP(thunk, a, c) < 0 ? c : a )) in med3()
89 :(CMP(thunk, b, c) > 0 ? b : (CMP(thunk, a, c) < 0 ? a : c )); in med3()
117 pl > (char *)a && CMP(thun in local_qsort()
[all...]
H A Dmerge.c60 #define CMP(x, y) CALL_BLOCK(cmp, x, y) macro
63 #define CMP(x, y) cmp(x, y) macro
144 if (CMP(f1, f2) <= 0) { in mergesort_b()
154 while ((b += size) < t && CMP(q, b) >sense) in mergesort_b()
163 CMP(q, p) <= sense) in mergesort_b()
168 } else if (CMP(q, p) <= sense) { in mergesort_b()
177 if (CMP(q, p = b + i) <= sense) in mergesort_b()
184 if (CMP(q, in mergesort_b()
268 sense = (CMP(f1, f1 + size) > 0); in setup()
273 if ((CMP(f2, f2+ size) > 0) != sense) in setup()
[all …]
/freebsd/crypto/heimdal/lib/roken/
H A Dqsort.c93 #define CMP(t, x, y) (cmp((t), (x), (y))) macro
95 #define CMP(t, x, y) (cmp((x), (y))) macro
105 return CMP(thunk, a, b) < 0 ? in med3()
106 (CMP(thunk, b, c) < 0 ? b : (CMP(thunk, a, c) < 0 ? c : a )) in med3()
107 :(CMP(thunk, b, c) > 0 ? b : (CMP(thunk, a, c) < 0 ? a : c )); in med3()
129 pl > (char *)a && CMP(thunk, pl - es, pl) > 0; in rk_qsort_r()
151 while (pb <= pc && (cmp_result = CMP(thunk, pb, a)) <= 0) { in rk_qsort_r()
159 while (pb <= pc && (cmp_result = CMP(thunk, pc, a)) >= 0) { in rk_qsort_r()
177 pl > (char *)a && CMP(thunk, pl - es, pl) > 0; in rk_qsort_r()
/freebsd/sys/libkern/
H A Dqsort.c88 #define CMP(t, x, y) (cmp((x), (y), (t))) macro
90 #define CMP(t, x, y) (cmp((x), (y))) macro
100 return CMP(thunk, a, b) < 0 ? in med3()
101 (CMP(thunk, b, c) < 0 ? b : (CMP(thunk, a, c) < 0 ? c : a )) in med3()
102 :(CMP(thunk, b, c) > 0 ? b : (CMP(thunk, a, c) < 0 ? a : c )); in med3()
124 pl > (char *)a && CMP(thunk, pl - es, pl) > 0;
147 while (pb <= pc && (cmp_result = CMP(thunk, pb, a)) <= 0) {
154 while (pb <= pc && (cmp_result = CMP(thun
[all...]
/freebsd/crypto/openssl/doc/man3/
H A DOSSL_CMP_MSG_http_perform.pod6 - client-side HTTP(S) transfer of a CMP request-response pair
18 CMP server specified in I<ctx> and returns the result obtained from it.
25 such as in BRSKI-AE where a pre-established TLS channel is reused for CMP.
30 The HTTP path (aka "CMP alias" in this context) to use is by default C</>,
46 CMP is defined in RFC 9810.
47 HTTP transfer for CMP is defined in RFC 9811.
52 returns the received CMP response message on success, else NULL.
60 The OpenSSL CMP support was added in OpenSSL 3.0.
H A DOSSL_CMP_CTX_new.pod71 - functions for managing the CMP client context data structure
127 /* CMP message header and extra certificates: */
181 This is the context API for using CMP (Certificate Management Protocol) with
196 clearing the internal CMP transaction (aka session) status, PKIStatusInfo,
200 All other field values (i.e., CMP options) are retained for potential reuse.
232 Number of seconds a CMP request-response message round trip
286 is provided as the newPkey or client's pkey component of the CMP context.
326 Send request or response messages without CMP-level protection.
341 validating signature-based protection in received CMP messages.
342 Else, 'digitalSignature' must be allowed by CMP signer certificates.
[all …]
H A DOSSL_CMP_SRV_CTX_new.pod25 - generic functions to set up and control a CMP server
98 of Certificate Management Protocol (CMP) servers.
99 Its arguments are the B<OSSL_CMP_SRV_CTX> I<srv_ctx> and a CMP request message
102 and then assembles a response message, which may be a CMP error message.
104 Since OSSL_CMP_SRV_process_request() handles only a single CMP request message,
105 it may need to be called multiple times until a CMP transaction has ended.
120 OSSL_CMP_SRV_process_request() that can be used by a CMP client
133 pointer as well as callback functions performing the specific processing of CMP
138 type of CMP message is not supported by the server.
173 CMP i
[all...]
H A DOSSL_CMP_log_open.pod52 convenience functions for CMP-specific logging,
55 messages produced by the CMP library in case of certificate validation failures.
59 A CMP application can obtain this information by providing a callback function
84 OSSL_CMP_log_open() initializes the CMP-specific logging facility to output
91 any pending CMP-specific log output and deallocate related resources.
97 If it is NULL, empty, or "(unknown function)" then "CMP" is used as fallback.
100 It is similar to L<ERR_print_errors_cb(3)> but uses the CMP log callback
101 function I<log_fn> for uniformity with CMP logging if not NULL. Otherwise it
113 The OpenSSL CMP support was added in OpenSSL 3.0.
H A DOSSL_CMP_STATUSINFO_new.pod8 - function(s) for managing the CMP PKIStatus
23 This is the PKIStatus API for using CMP (Certificate Management Protocol) with
37 representing the PKIStatusInfo components of the CMP context I<ctx>
42 CMP is defined in RFC 9810.
55 The OpenSSL CMP support was added in OpenSSL 3.0.
H A DOSSL_CMP_exec_certreq.pod21 - functions implementing CMP client transactions
54 This is the OpenSSL main API for Certificate Management Protocol (CMP) clients.
55 Each of the OSSL_CMP_exec_*() functions performs a whole CMP transaction,
56 which is a sequence of related CMP request messages and response messages.
59 Usually the server name, port, and path ("CMP alias") need to be set, as well as
103 OSSL_CMP_try_certreq() remembers in the CMP context that it should be retried
114 aborts the CMP transaction by sending an error message to the server.
146 to obtain a list of CA certificates from the CMP server referenced by I<ctx>.
152 with infoType rootCaCert to obtain from the CMP server referenced by I<ctx>
169 to obtain CRL from the CMP serve
[all...]
H A DOSSL_CMP_validate_msg.pod7 - functions for verifying CMP message protection
18 This is the API for validating the protection of CMP messages,
19 which includes validating CMP message sender certificates and their paths
24 In the former case a suitable trust anchor must be given in the CMP context
51 has not been authenticated (at least not at CMP level).
63 CMP is defined in RFC 9810.
78 The OpenSSL CMP support was added in OpenSSL 3.0.
H A DOSSL_CMP_MSG_get0_header.pod15 - function(s) manipulating CMP messages
34 OSSL_CMP_MSG_get0_header() returns the header of the given CMP message.
36 OSSL_CMP_MSG_get_bodytype() returns the body type of the given CMP message.
51 from various information provided in the CMP context argument I<ctx>
52 for inclusion in a CMP request message based on details contained in I<ctx>.
117 CMP is defined in RFC 9810.
134 return the parsed CMP message or NULL on error.
152 The OpenSSL CMP support was added in OpenSSL 3.0.
H A DOSSL_CMP_HDR_get0_transactionID.pod8 - functions manipulating CMP message headers
33 CMP is defined in RFC 9810.
42 The OpenSSL CMP support was added in OpenSSL 3.0.
/freebsd/contrib/byacc/test/
H A Drun_test.sh12 CMP=${REF_DIR}/${NEW}
13 if test ! -f "$CMP"
15 echo "...not found $CMP"
30 < "$CMP" >"$tmpfile" \
31 && mv "$tmpfile" "$CMP"
34 mv "$CMP" "$REF"
36 elif ( cmp -s "$REF" "$CMP" )
39 rm -f "$CMP"
42 diff -c "$REF" "$CMP"
/freebsd/crypto/openssl/doc/man1/
H A Dopenssl-cmp.pod.in6 openssl-cmp - Certificate Management Protocol (CMP, RFCs 9810 and 9811) application
167 Certificate verification options, for both CMP and TLS:
174 Management Protocol (CMP) as defined in RFCs 9810 and
178 request certificates to be revoked, and perform other types of CMP requests.
196 Section(s) to use within config file defining CMP options.
221 CMP command to execute.
336 the subject DN is used as fallback sender of outgoing CMP messages.
409 it is transformed into the respective regular CMP request.
418 Its subject is used as fallback sender in CMP message headers
479 Its issuer is used as default recipient in CMP message headers
[all …]
/freebsd/contrib/blocklist/bin/
H A Dconf.c445 #define CMP(a, b, f) \ in conf_sort() macro
449 CMP(c1, c2, c_ss.ss_family); in conf_sort()
450 CMP(c1, c2, c_lmask); in conf_sort()
451 CMP(c1, c2, c_port); in conf_sort()
452 CMP(c1, c2, c_proto); in conf_sort()
453 CMP(c1, c2, c_family); in conf_sort()
454 CMP(c1, c2, c_rmask); in conf_sort()
455 CMP(c1, c2, c_uid); in conf_sort()
456 #undef CMP in conf_sort()
702 #define CMP(a, b, f) \ in conf_eq() macro
[all …]
/freebsd/contrib/llvm-project/libc/include/llvm-libc-macros/linux/
H A Dsys-time-macros.h48 #define timercmp(timeval_ptr_a, timeval_ptr_b, CMP) \ argument
50 ? ((timeval_ptr_a)->tv_usec CMP(timeval_ptr_b)->tv_usec) \
51 : ((timeval_ptr_a)->tv_sec CMP(timeval_ptr_b)->tv_sec))
/freebsd/tools/test/sort/regression/
H A DMakefile10 CMP?= ${.CURDIR}/cmp.sh macro
17 @${CMP} ref/${f} output/${f}
23 @${CMP} ref/${f}${opt} output/${f}${opt}
/freebsd/crypto/openssl/doc/internal/man3/
H A Dossl_cmp_msg_protect.pod8 - functions for producing CMP message protection
35 If signature-based message protection is used it adds first the CMP signer cert
44 CMP is defined in RFC 9810.
48 because I<ctx->chain> may get adapted to cache the chain of the CMP signer cert.
58 The OpenSSL CMP support was added in OpenSSL 3.0.
H A Dossl_cmp_certreq_new.pod16 - functions for generating CMP messages
46 This is the internal API for creating various CMP PKIMESSAGES.
56 Available CMP certificate request PKIMessage I<bodytype>s are:
79 Available CMP certificate response PKIMessage I<bodytype>s are:
91 The list of all CMP PKIMessage I<bodytype>s is:
153 CMP is specified in RFC 9810 (and CRMF in RFC 4211).
167 The OpenSSL CMP support was added in OpenSSL 3.0.
H A Dossl_cmp_mock_srv_new.pod18 - functions used for testing with CMP mock server
44 ossl_cmp_mock_srv_new() allocates the contexts for the CMP mock server
48 ossl_cmp_mock_srv_free() deallocates the contexts for the CMP mock server.
88 CMP is defined in RFC 9810 (and CRMF in RFC 4211).
101 The OpenSSL CMP support was added in OpenSSL 3.0.
H A Dossl_cmp_ctx_set1_caPubs.pod13 - internal functions for managing the CMP client context datastructure
57 CMP is defined in RFC 9810.
65 The OpenSSL CMP support was added in OpenSSL 3.0.
/freebsd/crypto/openssl/util/
H A Dlibcrypto.num4601 OSSL_CMP_PKISTATUS_it 4729 3_0_0 EXIST::FUNCTION:CMP
4602 d2i_OSSL_CMP_PKIHEADER 4730 3_0_0 EXIST::FUNCTION:CMP
4603 i2d_OSSL_CMP_PKIHEADER 4731 3_0_0 EXIST::FUNCTION:CMP
4604 OSSL_CMP_PKIHEADER_free 4732 3_0_0 EXIST::FUNCTION:CMP
4605 OSSL_CMP_PKIHEADER_new 4733 3_0_0 EXIST::FUNCTION:CMP
4606 OSSL_CMP_PKIHEADER_it 4734 3_0_0 EXIST::FUNCTION:CMP
4607 d2i_OSSL_CMP_MSG 4735 3_0_0 EXIST::FUNCTION:CMP
4608 i2d_OSSL_CMP_MSG 4736 3_0_0 EXIST::FUNCTION:CMP
4609 OSSL_CMP_MSG_it 4737 3_0_0 EXIST::FUNCTION:CMP
4610 OSSL_CMP_ITAV_create 4738 3_0_0 EXIST::FUNCTION:CMP
[all …]
/freebsd/sys/contrib/device-tree/src/arm/microchip/
H A Dsama5d36ek_cmp.dts3 * sama5d36ek_cmp.dts - Device Tree file for SAMA5D36-EK CMP board
12 model = "Atmel SAMA5D36EK-CMP";
/freebsd/tools/test/iconv/
H A DMakefile34 CMP?= ${.CURDIR}/tablegen/cmp.sh macro
50 @${CMP} ${.CURDIR}/ref/${enc} ${.OBJDIR}/output/${enc}
53 @${CMP} ${.CURDIR}/ref/${enc}-rev ${.OBJDIR}/output/${enc}-rev

123456