xref: /freebsd/crypto/openssh/contrib/redhat/openssh.spec (revision 0ae642c7dd0c2cfd965a22bf73876cd26cceadd2)
1%global ver 9.9p2
2%global rel 1%{?dist}
3
4# OpenSSH privilege separation requires a user & group ID
5%global sshd_uid    74
6%global sshd_gid    74
7
8# Version of ssh-askpass
9%global aversion 1.2.4.1
10
11# Do we want to disable building of x11-askpass? (1=yes 0=no)
12%global no_x11_askpass 0
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%global no_gnome_askpass 0
16
17# Do we want to link against a static libcrypto? (1=yes 0=no)
18%global static_libcrypto 0
19
20# Do we want smartcard support (1=yes 0=no)
21%global scard 0
22
23# Use GTK2 instead of GNOME in gnome-ssh-askpass
24%global gtk2 1
25
26# Use build6x options for older RHEL builds
27# RHEL 7 not yet supported
28%if 0%{?rhel} > 6
29%global build6x 0
30%else
31%global build6x 1
32%endif
33
34%global without_openssl 0
35# build without openssl where 1.1.1 is not available
36%if %{defined fedora} && 0%{?fedora} <= 28
37%global without_openssl 1
38%endif
39%if %{defined rhel} && 0%{?rhel} <= 7
40%global without_openssl 1
41%endif
42
43# Do we want kerberos5 support (1=yes 0=no)
44%global kerberos5 1
45
46# Reserve options to override askpass settings with:
47# rpm -ba|--rebuild --define 'skip_xxx 1'
48%{?skip_x11_askpass:%global no_x11_askpass 1}
49%{?skip_gnome_askpass:%global no_gnome_askpass 1}
50
51# Add option to build without GTK2 for older platforms with only GTK+.
52# RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
53# rpm -ba|--rebuild --define 'no_gtk2 1'
54%{?no_gtk2:%global gtk2 0}
55
56# Is this a build for RHL 6.x or earlier?
57%{?build_6x:%global build6x 1}
58
59# If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
60%if %{build6x}
61%global _sysconfdir /etc
62%endif
63
64# Options for static OpenSSL link:
65# rpm -ba|--rebuild --define "static_openssl 1"
66%{?static_openssl:%global static_libcrypto 1}
67
68# Options for Smartcard support: (needs libsectok and openssl-engine)
69# rpm -ba|--rebuild --define "smartcard 1"
70%{?smartcard:%global scard 1}
71
72# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
73%global rescue 0
74%{?build_rescue:%global rescue 1}
75
76# Turn off some stuff for resuce builds
77%if %{rescue}
78%global kerberos5 0
79%endif
80
81Summary: The OpenSSH implementation of SSH protocol version 2.
82Name: openssh
83Version: %{ver}
84%if %{rescue}
85Release: %{rel}rescue
86%else
87Release: %{rel}
88%endif
89URL: https://www.openssh.com/portable.html
90Source0: https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
91Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
92License: BSD
93Group: Applications/Internet
94BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
95Obsoletes: ssh
96%if %{build6x}
97PreReq: initscripts >= 5.00
98%else
99Requires: initscripts >= 5.20
100%endif
101BuildRequires: perl
102%if ! %{without_openssl}
103BuildRequires: openssl-devel >= 1.1.1
104%endif
105BuildRequires: /bin/login
106%if ! %{build6x}
107BuildRequires: glibc-devel, pam
108%else
109BuildRequires: /usr/include/security/pam_appl.h
110%endif
111%if ! %{no_x11_askpass}
112BuildRequires: /usr/include/X11/Xlib.h
113# Xt development tools
114BuildRequires: libXt-devel
115# Provides xmkmf
116BuildRequires: imake
117# Rely on relatively recent gtk
118BuildRequires: gtk2-devel
119%endif
120%if ! %{no_gnome_askpass}
121BuildRequires: pkgconfig
122%endif
123%if %{kerberos5}
124BuildRequires: krb5-devel
125BuildRequires: krb5-libs
126%endif
127
128%package clients
129Summary: OpenSSH clients.
130Requires: openssh = %{version}-%{release}
131Group: Applications/Internet
132Obsoletes: ssh-clients
133
134%package server
135Summary: The OpenSSH server daemon.
136Group: System Environment/Daemons
137Obsoletes: ssh-server
138Requires: openssh = %{version}-%{release}, chkconfig >= 0.9
139%if ! %{build6x}
140Requires: /etc/pam.d/system-auth
141%endif
142
143%package askpass
144Summary: A passphrase dialog for OpenSSH and X.
145Group: Applications/Internet
146Requires: openssh = %{version}-%{release}
147Obsoletes: ssh-extras
148
149%package askpass-gnome
150Summary: A passphrase dialog for OpenSSH, X, and GNOME.
151Group: Applications/Internet
152Requires: openssh = %{version}-%{release}
153Obsoletes: ssh-extras
154
155%description
156SSH (Secure SHell) is a program for logging into and executing
157commands on a remote machine. SSH is intended to replace rlogin and
158rsh, and to provide secure encrypted communications between two
159untrusted hosts over an insecure network. X11 connections and
160arbitrary TCP/IP ports can also be forwarded over the secure channel.
161
162OpenSSH is OpenBSD's version of the last free version of SSH, bringing
163it up to date in terms of security and features, as well as removing
164all patented algorithms to separate libraries.
165
166This package includes the core files necessary for both the OpenSSH
167client and server. To make this package useful, you should also
168install openssh-clients, openssh-server, or both.
169
170%description clients
171OpenSSH is a free version of SSH (Secure SHell), a program for logging
172into and executing commands on a remote machine. This package includes
173the clients necessary to make encrypted connections to SSH servers.
174You'll also need to install the openssh package on OpenSSH clients.
175
176%description server
177OpenSSH is a free version of SSH (Secure SHell), a program for logging
178into and executing commands on a remote machine. This package contains
179the secure shell daemon (sshd). The sshd daemon allows SSH clients to
180securely connect to your SSH server. You also need to have the openssh
181package installed.
182
183%description askpass
184OpenSSH is a free version of SSH (Secure SHell), a program for logging
185into and executing commands on a remote machine. This package contains
186an X11 passphrase dialog for OpenSSH.
187
188%description askpass-gnome
189OpenSSH is a free version of SSH (Secure SHell), a program for logging
190into and executing commands on a remote machine. This package contains
191an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
192environment.
193
194%prep
195
196%if ! %{no_x11_askpass}
197%setup -q -a 1
198%else
199%setup -q
200%endif
201
202%build
203%if %{rescue}
204CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
205%endif
206
207%configure \
208	--sysconfdir=%{_sysconfdir}/ssh \
209	--libexecdir=%{_libexecdir}/openssh \
210	--datadir=%{_datadir}/openssh \
211	--with-default-path=/usr/local/bin:/bin:/usr/bin \
212	--with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
213	--with-privsep-path=%{_var}/empty/sshd \
214	--mandir=%{_mandir} \
215	--with-mantype=man \
216	--disable-strip \
217%if %{without_openssl}
218	--without-openssl \
219%endif
220%if %{scard}
221	--with-smartcard \
222%endif
223%if %{rescue}
224	--without-pam \
225%else
226	--with-pam \
227%endif
228%if %{kerberos5}
229	 --with-kerberos5=$K5DIR \
230%endif
231
232
233%if %{static_libcrypto}
234perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
235%endif
236
237make
238
239%if ! %{no_x11_askpass}
240pushd x11-ssh-askpass-%{aversion}
241%configure --libexecdir=%{_libexecdir}/openssh
242xmkmf -a
243make
244popd
245%endif
246
247# Define a variable to toggle gnome1/gtk2 building.  This is necessary
248# because RPM doesn't handle nested %if statements.
249%if %{gtk2}
250	gtk2=yes
251%else
252	gtk2=no
253%endif
254
255%if ! %{no_gnome_askpass}
256pushd contrib
257if [ $gtk2 = yes ] ; then
258	make gnome-ssh-askpass2
259	mv gnome-ssh-askpass2 gnome-ssh-askpass
260else
261	make gnome-ssh-askpass1
262	mv gnome-ssh-askpass1 gnome-ssh-askpass
263fi
264popd
265%endif
266
267%install
268rm -rf $RPM_BUILD_ROOT
269mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
270mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
271mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
272
273make install DESTDIR=$RPM_BUILD_ROOT
274
275install -d $RPM_BUILD_ROOT/etc/pam.d/
276install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
277install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
278install -m644 contrib/redhat/sshd.pam  $RPM_BUILD_ROOT/etc/pam.d/sshd
279install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
280
281%if ! %{no_x11_askpass}
282install x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
283ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
284%endif
285
286%if ! %{no_gnome_askpass}
287install contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
288%endif
289
290%if ! %{scard}
291	 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
292%endif
293
294%if ! %{no_gnome_askpass}
295install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
296install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
297install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
298%endif
299
300perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
301
302%clean
303rm -rf $RPM_BUILD_ROOT
304
305%triggerun server -- ssh-server
306if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
307	touch /var/run/sshd.restart
308fi
309
310%triggerun server -- openssh-server < 2.5.0p1
311# Count the number of HostKey and HostDsaKey statements we have.
312gawk	'BEGIN {IGNORECASE=1}
313	 /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
314	 END {exit sawhostkey}' /etc/ssh/sshd_config
315# And if we only found one, we know the client was relying on the old default
316# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
317# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
318# one nullifies the default, which would have loaded both.
319if [ $? -eq 1 ] ; then
320	echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
321	echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
322fi
323
324%triggerpostun server -- ssh-server
325if [ "$1" != 0 ] ; then
326	/sbin/chkconfig --add sshd
327	if test -f /var/run/sshd.restart ; then
328		rm -f /var/run/sshd.restart
329		/sbin/service sshd start > /dev/null 2>&1 || :
330	fi
331fi
332
333%pre server
334%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
335%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
336	-g sshd -M -r sshd 2>/dev/null || :
337
338%post server
339/sbin/chkconfig --add sshd
340
341%postun server
342/sbin/service sshd condrestart > /dev/null 2>&1 || :
343
344%preun server
345if [ "$1" = 0 ]
346then
347	/sbin/service sshd stop > /dev/null 2>&1 || :
348	/sbin/chkconfig --del sshd
349fi
350
351%files
352%defattr(-,root,root)
353%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO
354%attr(0755,root,root) %{_bindir}/scp
355%attr(0644,root,root) %{_mandir}/man1/scp.1*
356%attr(0755,root,root) %dir %{_sysconfdir}/ssh
357%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
358%if ! %{rescue}
359%attr(0755,root,root) %{_bindir}/ssh-keygen
360%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
361%attr(0755,root,root) %dir %{_libexecdir}/openssh
362%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
363%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
364%attr(0755,root,root) %{_libexecdir}/openssh/ssh-sk-helper
365%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
366%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
367%attr(0644,root,root) %{_mandir}/man8/ssh-sk-helper.8*
368%endif
369%if %{scard}
370%attr(0755,root,root) %dir %{_datadir}/openssh
371%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
372%endif
373
374%files clients
375%defattr(-,root,root)
376%attr(0755,root,root) %{_bindir}/ssh
377%attr(0644,root,root) %{_mandir}/man1/ssh.1*
378%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
379%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
380%if ! %{rescue}
381%attr(2755,root,nobody) %{_bindir}/ssh-agent
382%attr(0755,root,root) %{_bindir}/ssh-add
383%attr(0755,root,root) %{_bindir}/ssh-keyscan
384%attr(0755,root,root) %{_bindir}/sftp
385%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
386%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
387%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
388%attr(0644,root,root) %{_mandir}/man1/sftp.1*
389%endif
390
391%if ! %{rescue}
392%files server
393%defattr(-,root,root)
394%dir %attr(0111,root,root) %{_var}/empty/sshd
395%attr(0755,root,root) %{_sbindir}/sshd
396%attr(0755,root,root) %{_libexecdir}/openssh/sshd-session
397%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
398%attr(0644,root,root) %{_mandir}/man8/sshd.8*
399%attr(0644,root,root) %{_mandir}/man5/moduli.5*
400%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
401%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
402%attr(0755,root,root) %dir %{_sysconfdir}/ssh
403%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
404%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
405%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
406%endif
407
408%if ! %{no_x11_askpass}
409%files askpass
410%defattr(-,root,root)
411%doc x11-ssh-askpass-%{aversion}/README
412%doc x11-ssh-askpass-%{aversion}/ChangeLog
413%doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
414%{_libexecdir}/openssh/ssh-askpass
415%attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
416%endif
417
418%if ! %{no_gnome_askpass}
419%files askpass-gnome
420%defattr(-,root,root)
421%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
422%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
423%endif
424
425%changelog
426* Mon Oct 16 2023 Fabio Pedretti <pedretti.fabio@gmail.com>
427- Remove reference of dropped sshd.pam.old file
428- Update openssl-devel dependency to require >= 1.1.1
429- Build with --without-openssl elsewhere
430
431* Thu Oct 28 2021 Damien Miller <djm@mindrot.org>
432- Remove remaining traces of --with-md5-passwords
433
434* Mon Jul 20 2020 Damien Miller <djm@mindrot.org>
435- Add ssh-sk-helper and corresponding manual page.
436
437* Sat Feb 10 2018 Darren Tucker <dtucker@dtucker.net>
438- Update openssl-devel dependency to match current requirements.
439- Handle Fedora >=6 openssl 1.0 compat libs.
440- Remove SSH1 from description.
441- Don't strip binaries at build time so that debuginfo package can be
442  created.
443
444* Sun Nov 16 2014 Nico Kadel-Garcia <nakdel@gmail.com>
445- Add '--mandir' and '--with-mantype' for RHEL 5 compatibility
446- Add 'dist' option to 'ver' so package names reflect OS at build time
447- Always include x11-ssh-askpass tarball in SRPM
448- Add openssh-x11-aspass BuildRequires for libXT-devel, imake, gtk2-devel
449- Discard 'K5DIR' reporting, not usable inside 'mock' for RHEL 5 compatibility
450- Discard obsolete '--with-rsh' configure option
451- Update openssl-devel dependency to 0.9.8f, as found in autoconf
452
453* Wed Jul 14 2010 Tim Rice <tim@multitalents.net>
454- test for skip_x11_askpass (line 77) should have been for no_x11_askpass
455
456* Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
457- Remove noip6 option. This may be controlled at run-time in client config
458  file using new AddressFamily directive
459
460* Mon May 12 2003 Damien Miller <djm@mindrot.org>
461- Don't install profile.d scripts when not building with GNOME/GTK askpass
462  (patch from bet@rahul.net)
463
464* Tue Oct 01 2002 Damien Miller <djm@mindrot.org>
465- Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
466
467* Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
468- Use contrib/ Makefile for building askpass programs
469
470* Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
471- Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
472- Add new {ssh,sshd}_config.5 manpages
473- Add new ssh-keysign program and remove setuid from ssh client
474
475* Fri May 10 2002 Damien Miller <djm@mindrot.org>
476- Merge in spec changes from RedHat, reorgansie a little
477- Add Privsep user, group and directory
478
479* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
480- bump and grind (through the build system)
481
482* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
483- require sharutils for building (mindrot #137)
484- require db1-devel only when building for 6.x (#55105), which probably won't
485  work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
486- require pam-devel by file (not by package name) again
487- add Markus's patch to compile with OpenSSL 0.9.5a (from
488  http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
489  building for 6.x
490
491* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
492- update to 3.1p1
493
494* Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
495- update to SNAP-20020305
496- drop debug patch, fixed upstream
497
498* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
499- update to SNAP-20020220 for testing purposes (you've been warned, if there's
500  anything to be warned about, gss patches won't apply, I don't mind)
501
502* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
503- add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
504  exchange, authentication, and named key support
505
506* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
507- remove dependency on db1-devel, which has just been swallowed up whole
508  by gnome-libs-devel
509
510* Sat Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
511- adjust build dependencies so that build6x actually works right (fix
512  from Hugo van der Kooij)
513
514* Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
515- update to 3.0.2p1
516
517* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
518- update to 3.0.1p1
519
520* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
521- update to current CVS (not for use in distribution)
522
523* Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
524- merge some of Damien Miller <djm@mindrot.org> changes from the upstream
525  3.0p1 spec file and init script
526
527* Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
528- update to 3.0p1
529- update to x11-ssh-askpass 1.2.4.1
530- change build dependency on a file from pam-devel to the pam-devel package
531- replace primes with moduli
532
533* Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
534- incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
535
536* Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
537- Merge changes to rescue build from current sysadmin survival cd
538
539* Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
540- fix scp's server's reporting of file sizes, and build with the proper
541  preprocessor define to get large-file capable open(), stat(), etc.
542  (sftp has been doing this correctly all along) (#51827)
543- configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
544- pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
545- mark profile.d scriptlets as config files (#42337)
546- refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
547- change a couple of log() statements to debug() statements (#50751)
548- pull cvs patch to add -t flag to sshd (#28611)
549- clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
550
551* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
552- add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
553
554* Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
555- pull cvs patch to fix remote port forwarding with protocol 2
556
557* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
558- pull cvs patch to add session initialization to no-pty sessions
559- pull cvs patch to not cut off challengeresponse auth needlessly
560- refuse to do X11 forwarding if xauth isn't there, handy if you enable
561  it by default on a system that doesn't have X installed (#49263)
562
563* Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
564- don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
565
566* Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
567- pass OPTIONS correctly to initlog (#50151)
568
569* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
570- switch to x11-ssh-askpass 1.2.2
571
572* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
573- rebuild in new environment
574
575* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
576- disable the gssapi patch
577
578* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
579- update to 2.9p2
580- refresh to a new version of the gssapi patch
581
582* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
583- change Copyright: BSD to License: BSD
584- add Markus Friedl's unverified patch for the cookie file deletion problem
585  so that we can verify it
586- drop patch to check if xauth is present (was folded into cookie patch)
587- don't apply gssapi patches for the errata candidate
588- clear supplemental groups list at startup
589
590* Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
591- fix an error parsing the new default sshd_config
592- add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
593  dealing with comments right
594
595* Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
596- add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
597  to be removed before the next beta cycle because it's a big departure
598  from the upstream version
599
600* Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
601- finish marking strings in the init script for translation
602- modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
603  at startup (change merged from openssh.com init script, originally by
604  Pekka Savola)
605- refuse to do X11 forwarding if xauth isn't there, handy if you enable
606  it by default on a system that doesn't have X installed
607
608* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
609- update to 2.9
610- drop various patches that came from or went upstream or to or from CVS
611
612* Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
613- only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
614
615* Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
616- remove explicit openssl requirement, fixes builddistro issue
617- make initscript stop() function wait until sshd really dead to avoid
618  races in condrestart
619
620* Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
621- mention that challengereponse supports PAM, so disabling password doesn't
622  limit users to pubkey and rsa auth (#34378)
623- bypass the daemon() function in the init script and call initlog directly,
624  because daemon() won't start a daemon it detects is already running (like
625  open connections)
626- require the version of openssl we had when we were built
627
628* Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
629- make do_pam_setcred() smart enough to know when to establish creds and
630  when to reinitialize them
631- add in a couple of other fixes from Damien for inclusion in the errata
632
633* Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
634- update to 2.5.2p2
635- call setcred() again after initgroups, because the "creds" could actually
636  be group memberships
637
638* Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
639- update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
640- don't enable challenge-response by default until we find a way to not
641  have too many userauth requests (we may make up to six pubkey and up to
642  three password attempts as it is)
643- remove build dependency on rsh to match openssh.com's packages more closely
644
645* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
646- remove dependency on openssl -- would need to be too precise
647
648* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
649- rebuild in new environment
650
651* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
652- Revert the patch to move pam_open_session.
653- Init script and spec file changes from Pekka Savola. (#28750)
654- Patch sftp to recognize '-o protocol' arguments. (#29540)
655
656* Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
657- Chuck the closing patch.
658- Add a trigger to add host keys for protocol 2 to the config file, now that
659  configuration file syntax requires us to specify it with HostKey if we
660  specify any other HostKey values, which we do.
661
662* Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
663- Redo patch to move pam_open_session after the server setuid()s to the user.
664- Rework the nopam patch to use be picked up by autoconf.
665
666* Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
667- Update for 2.5.1p1.
668- Add init script mods from Pekka Savola.
669- Tweak the init script to match the CVS contrib script more closely.
670- Redo patch to ssh-add to try to adding both identity and id_dsa to also try
671  adding id_rsa.
672
673* Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
674- Update for 2.5.0p1.
675- Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
676- Resync with parts of Damien Miller's openssh.spec from CVS, including
677  update of x11 askpass to 1.2.0.
678- Only require openssl (don't prereq) because we generate keys in the init
679  script now.
680
681* Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
682- Don't open a PAM session until we've forked and become the user (#25690).
683- Apply Andrew Bartlett's patch for letting pam_authenticate() know which
684  host the user is attempting a login from.
685- Resync with parts of Damien Miller's openssh.spec from CVS.
686- Don't expose KbdInt responses in debug messages (from CVS).
687- Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
688
689* Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
690- i18n-tweak to initscript.
691
692* Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
693- More gettextizing.
694- Close all files after going into daemon mode (needs more testing).
695- Extract patch from CVS to handle auth banners (in the client).
696- Extract patch from CVS to handle compat weirdness.
697
698* Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
699- Finish with the gettextizing.
700
701* Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
702- Fix a bug in auth2-pam.c (#23877)
703- Gettextize the init script.
704
705* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
706- Incorporate a switch for using PAM configs for 6.x, just in case.
707
708* Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
709- Incorporate Bero's changes for a build specifically for rescue CDs.
710
711* Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
712- Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
713  succeeded, to allow public-key authentication after a failure with "none"
714  authentication.  (#21268)
715
716* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
717- Update to x11-askpass 1.1.1. (#21301)
718- Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
719
720* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
721- Merge multiple PAM text messages into subsequent prompts when possible when
722  doing keyboard-interactive authentication.
723
724* Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
725- Disable the built-in MD5 password support.  We're using PAM.
726- Take a crack at doing keyboard-interactive authentication with PAM, and
727  enable use of it in the default client configuration so that the client
728  will try it when the server disallows password authentication.
729- Build with debugging flags.  Build root policies strip all binaries anyway.
730
731* Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
732- Use DESTDIR instead of %%makeinstall.
733- Remove /usr/X11R6/bin from the path-fixing patch.
734
735* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
736- Add the primes file from the latest snapshot to the main package (#20884).
737- Add the dev package to the prereq list (#19984).
738- Remove the default path and mimic login's behavior in the server itself.
739
740* Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
741- Resync with conditional options in Damien Miller's .spec file for an errata.
742- Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
743
744* Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
745- Update to OpenSSH 2.3.0p1.
746- Update to x11-askpass 1.1.0.
747- Enable keyboard-interactive authentication.
748
749* Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
750- Update to ssh-askpass-x11 1.0.3.
751- Change authentication related messages to be private (#19966).
752
753* Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
754- Patch ssh-keygen to be able to list signatures for DSA public key files
755  it generates.
756
757* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
758- Add BuildRequires on /usr/include/security/pam_appl.h to be sure we always
759  build PAM authentication in.
760- Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
761- Clean out no-longer-used patches.
762- Patch ssh-add to try to add both identity and id_dsa, and to error only
763  when neither exists.
764
765* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
766- Update x11-askpass to 1.0.2. (#17835)
767- Add BuildRequiress for /bin/login and /usr/bin/rsh so that configure will
768  always find them in the right place. (#17909)
769- Set the default path to be the same as the one supplied by /bin/login, but
770  add /usr/X11R6/bin. (#17909)
771- Try to handle obsoletion of ssh-server more cleanly.  Package names
772  are different, but init script name isn't. (#17865)
773
774* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
775- Update to 2.2.0p1. (#17835)
776- Tweak the init script to allow proper restarting. (#18023)
777
778* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
779- Update to 20000823 snapshot.
780- Change subpackage requirements from %%{version} to %%{version}-%%{release}
781- Back out the pipe patch.
782
783* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
784- Update to 2.1.1p4, which includes fixes for config file parsing problems.
785- Move the init script back.
786- Add Damien's quick fix for wackiness.
787
788* Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
789- Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
790
791* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
792- Move condrestart to server postun.
793- Move key generation to init script.
794- Actually use the right patch for moving the key generation to the init script.
795- Clean up the init script a bit.
796
797* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
798- Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
799
800* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
801- Update to 2.1.1p2.
802- Use of strtok() considered harmful.
803
804* Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
805- Get the build root out of the man pages.
806
807* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
808- Add and use condrestart support in the init script.
809- Add newer initscripts as a prereq.
810
811* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
812- Build in new environment (release 2)
813- Move -clients subpackage to Applications/Internet group
814
815* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
816- Update to 2.2.1p1
817
818* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
819- Patch to build with neither RSA nor RSAref.
820- Miscellaneous FHS-compliance tweaks.
821- Fix for possibly-compressed man pages.
822
823* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
824- Updated for new location
825- Updated for new gnome-ssh-askpass build
826
827* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
828- Added Jim Knoble's <jmknoble@pobox.com> askpass
829
830* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
831- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
832
833* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
834- Added 'Obsoletes' directives
835
836* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
837- Use make install
838- Subpackages
839
840* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
841- Added links for slogin
842- Fixed perms on manpages
843
844* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
845- Renamed init script
846
847* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
848- Back to old binary names
849
850* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
851- Use autoconf
852- New binary names
853
854* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
855- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
856