| /linux/Documentation/RCU/ |
| H A D | checklist.rst | 32 for lockless updates. This does result in the mildly 34 rcu_read_unlock() are used to protect updates, however, this 45 c. restricting updates to a single task. 94 be running while updates are in progress. There are a number 113 c. Make updates appear atomic to readers. For example, 114 pointer updates to properly aligned fields will 125 d. Carefully order the updates and the reads so that readers 197 e. Updates must ensure that initialization of a given 228 Restructure your code so that it batches the updates, allowing 293 primitive will correspondingly delay updates. In contrast, [all …]
|
| /linux/drivers/base/firmware_loader/ |
| H A D | Kconfig | 14 o /lib/firmware/updates/UTS_RELEASE 15 o /lib/firmware/updates 225 bool "Enable users to initiate firmware updates using sysfs" 230 sysfs interface that allows firmware updates to be initiated from 234 to support cards that rely on user-initiated updates for firmware files.
|
| /linux/drivers/gpu/drm/amd/amdgpu/ |
| H A D | amdgpu_hmm.c | 35 * about updates on the page tables of a process. 122 * amdgpu_hmm_register - register a BO for notifier updates 154 * amdgpu_hmm_unregister - unregister a BO for notifier updates 158 * Remove any registration of mmu notifier updates from the buffer object. 233 * by concurrent address space updates before it is accessed.
|
| /linux/drivers/net/ |
| H A D | LICENSE.SRC | 14 on an "as-is" basis. No further updates to this software should be 15 expected. Although updates may occur, no commitment exists.
|
| /linux/drivers/net/ethernet/netronome/nfp/flower/ |
| H A D | main.h | 268 * @stats: Stored stats updates for flower rules 269 * @stats_lock: Lock for flower rule stats updates 289 * @qos_stats_lock: Lock on qos stats updates 290 * @meter_stats_lock: Lock on meter stats updates 299 * @predt_lock: Lock to serialise predt/neigh table updates 342 spinlock_t predt_lock; /* Lock to serialise predt/neigh table updates */ 349 * @curr_stats: Currently stored stats updates for qos info 350 * @prev_stats: Previously stored updates for qos info
|
| /linux/drivers/gpu/drm/radeon/ |
| H A D | radeon_mn.c | 88 * radeon_mn_register - register a BO for notifier updates 116 * radeon_mn_unregister - unregister a BO for notifier updates 120 * Remove any registration of MMU notifier updates from the buffer object.
|
| /linux/Documentation/driver-api/firmware/ |
| H A D | fw_search_path.rst | 9 * /lib/firmware/updates/UTS_RELEASE/ 10 * /lib/firmware/updates/
|
| /linux/include/linux/mfd/ |
| H A D | lochnagar.h | 29 * @analogue_config_lock: Lock used to protect updates in the analogue 38 /* Lock to protect updates to the analogue configuration */
|
| /linux/drivers/virt/coco/tdx-host/ |
| H A D | tdx-host.c | 35 * Lock out updates while printing the version. in version_show() 88 * These attributes are intended for managing TDX module updates. Reading 173 * TDX module updates are not cancellable. in tdx_fw_cancel()
|
| /linux/sound/pci/ctxfi/ |
| H A D | cttimer.c | 60 * system-timer-based updates 167 * also updates the each stream position, returns the number of streams 176 int updates = 0; in ct_xfitimer_reprogram() local 201 updates++; in ct_xfitimer_reprogram() 218 return updates; in ct_xfitimer_reprogram()
|
| /linux/sound/soc/sof/ |
| H A D | ipc3-control.c | 191 /* notify DSP of mixer updates */ in sof_ipc3_volume_put() 196 dev_err(scomp->dev, "Failed to set mixer updates for %s\n", in sof_ipc3_volume_put() 239 /* notify DSP of mixer updates */ in sof_ipc3_switch_put() 244 dev_err(scomp->dev, "Failed to set mixer updates for %s\n", in sof_ipc3_switch_put() 287 /* notify DSP of enum updates */ in sof_ipc3_enum_put() 292 dev_err(scomp->dev, "Failed to set enum updates for %s\n", in sof_ipc3_enum_put() 368 /* notify DSP of byte control updates */ in sof_ipc3_bytes_ext_put() 452 /* notify DSP of byte control updates */
|
| /linux/arch/sparc/include/asm/ |
| H A D | prom.h | 13 * Updates for PPC64 by Peter Bergner & David Engebretsen, IBM Corp. 14 * Updates for SPARC by David S. Miller
|
| /linux/arch/um/include/asm/ |
| H A D | tlbflush.h | 15 * To track updates, we can hook into set_ptes and flush_tlb_*. With set_ptes 20 * So, we simply track updates using both methods and mark the memory area to
|
| /linux/arch/powerpc/kernel/ |
| H A D | pci-hotplug.c | 8 * Updates, 2005, John Rose <johnrose@austin.ibm.com> 9 * Updates, 2005, Linas Vepstas <linas@austin.ibm.com> 10 * Updates, 2013, Gavin Shan <shangw@linux.vnet.ibm.com>
|
| /linux/rust/kernel/sync/atomic/ |
| H A D | internal.rs | 304 /// Atomically updates `*a` to `v` and returns the old value. 312 /// If `*a` == `*old`, atomically updates `*a` to `new`. Otherwise, `*a` is not 332 /// Atomically updates `*a` to `(*a).wrapping_add(v)`. 340 /// Atomically updates `*a` to `(*a).wrapping_add(v)`, and returns the value of `*a`
|
| /linux/fs/xfs/ |
| H A D | xfs_refcount_item.c | 272 /* Log refcount updates in the intent item. */ 345 /* Get an CUD so we can process all the deferred refcount updates. */ 373 * Deferred refcount updates for the realtime and data sections must in xfs_refcount_defer_add() 374 * use separate transactions to finish deferred work because updates to in xfs_refcount_defer_add() 377 * section updates. in xfs_refcount_defer_add() 535 * Under normal operation, refcount updates are deferred, so we in xfs_refcount_recover_work() 537 * refcount updates manage reservation usage internally and in xfs_refcount_recover_work()
|
| H A D | xfs_mount.h | 321 * growfs, and used by the pNFS server to ensure the client updates 344 /* Hook to feed dirent updates to an active online repair. */ 576 /* Kernel has logged a warning about logged xattr updates being used. */ in __XFS_HAS_FEAT() 712 * only occurs on frequent small block count updates such as in the delayed 713 * allocation path for buffered writes (page a time updates). Hence we set 714 * a large batch count (1024) to minimise global counter updates except when 715 * we get near to ENOSPC and we have to be very accurate with our updates. 742 * This just provides and estimate without the cpu-local updates, use
|
| /linux/drivers/gpu/drm/msm/disp/mdp5/ |
| H A D | mdp5_smp.h | 31 * On atomic updates that modify SMP configuration, the state is cloned 36 * Because the SMP registers are not double buffered, updates are a
|
| /linux/drivers/gpu/drm/msm/ |
| H A D | msm_mmu.h | 36 * struct msm_mmu_prealloc - Tracking for pre-allocated pages for MMU updates. 44 * @pages: Array of pages preallocated for MMU table updates.
|
| /linux/drivers/misc/mei/ |
| H A D | Kconfig | 103 Late Binding is a method for applying firmware updates at runtime, 105 fan controller or voltage regulator. These firmware updates are
|
| /linux/arch/mips/include/asm/octeon/ |
| H A D | cvmx-cmd-queue.h | 319 * updates. If you don't use this locking you must ensure 404 /* All updates are complete. Release the lock and return */ in cvmx_cmd_queue_write() 417 * updates. If you don't use this locking you must ensure 503 /* All updates are complete. Release the lock and return */ in cvmx_cmd_queue_write2() 516 * updates. If you don't use this locking you must ensure 613 /* All updates are complete. Release the lock and return */ in cvmx_cmd_queue_write3()
|
| /linux/include/linux/ |
| H A D | iversion.h | 17 * if the ctime does not (since the whole point is to avoid missing updates due 50 * It may be impractical for filesystems to keep i_version updates atomic with 52 * that i_version updates are never visible before the changes that caused 53 * them. Also, i_version updates should never be delayed longer than it takes
|
| /linux/include/uapi/linux/ |
| H A D | snmp.h | 14 * RFC 2011 (updates 1213): SNMPv2-MIB-IP 67 * RFC 2011 (updates 1213): SNMPv2 MIB for IP: ICMP group 127 * RFC 2012 (updates 1213): SNMPv2-MIB-TCP 153 * RFC 2013 (updates 1213): SNMPv2-MIB-UDP
|
| /linux/drivers/gpu/drm/xe/ |
| H A D | xe_mem_pool.c | 29 * a shadow BO that can be used for atomic updates to the primary BO's contents. 40 /** @shadow: Shadow BO for atomic command updates. */ 113 * initialized for atomic updates to the primary BO's contents. 206 * pool. This allows for atomic updates to the contents of the primary BO
|
| /linux/security/selinux/ |
| H A D | status.c | 77 * It updates status of the current enforcing/permissive mode. 101 * It updates status of the times of policy reloaded, and current
|