Lines Matching +full:zlib +full:- +full:dev

8 # The version of x11-ssh-askpass to use
11 # Allow the ability to override defaults with -D skip_xxx=1
19 Source0: openssh-%{version}.tar.gz
20 Source1: x11-ssh-askpass-%{xversion}.tar.gz
23 BuildRoot: %{_tmppath}/openssh-%{version}-buildroot
29 # building prerequisites -- stuff for
30 # OpenSSL (openssl-devel),
34 BuildPrereq: zlib-devel
43 Obsoletes: ssh-extras
44 Provides: openssh:${_libdir}/ssh/ssh-askpass
47 BuildPrereq: XFree86-devel
79 - Add ssh-sk-helper and corresponding manual page.
81 - Removed accidental inclusion of --without-zlib-version-check
83 - Overhaul to deal with newer versions of SuSE and OpenSSH
85 - Glob manpages to catch compressed files
87 - Updated for new location
88 - Updated for new gnome-ssh-askpass build
90 - Made symlink to gnome-ssh-askpass called ssh-askpass
92 - Removed patches that included /etc/pam.d/sshd, /sbin/init.d/rc.sshd, and
93 /var/adm/fillup-templates/rc.config.sshd, since Damien merged these into
95 - Changed permissions on ssh_config in the install procedure to 644 from 600
97 - Postinstall script for the server now only prints "Generating SSH host
100 - Marked all manual pages as %doc(umentation)
102 - Added flag to configure daemon with TCP Wrappers support
103 - Added building prerequisites (works in RPM 3.0 and newer)
105 - Made this package correct for SuSE.
106 - Changed instances of pam_pwdb.so to pam_unix.so, since it works more properly
109 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
111 - Added 'Obsoletes' directives
113 - Use make install
114 - Subpackages
116 - Added links for slogin
117 - Fixed perms on manpages
119 - Renamed init script
121 - Back to old binary names
123 - Use autoconf
124 - New binary names
126 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
131 %setup -q -a 1
133 %setup -q
138 %configure --prefix=/usr \
139 --sysconfdir=%{_sysconfdir}/ssh \
140 --mandir=%{_mandir} \
141 --with-privsep-path=/var/lib/empty \
142 --with-pam \
143 --libexecdir=%{_libdir}/ssh
147 cd x11-ssh-askpass-%{xversion}
148 %configure --mandir=/usr/X11R6/man \
149 --libexecdir=%{_libdir}/ssh
150 xmkmf -a
156 rm -rf $RPM_BUILD_ROOT
158 install -d $RPM_BUILD_ROOT/etc/pam.d/
159 install -d $RPM_BUILD_ROOT/etc/init.d/
160 install -d $RPM_BUILD_ROOT/var/adm/fillup-templates
161 install -m644 contrib/sshd.pam.generic $RPM_BUILD_ROOT/etc/pam.d/sshd
162 install -m744 contrib/suse/rc.sshd $RPM_BUILD_ROOT/etc/init.d/sshd
163 install -m744 contrib/suse/sysconfig.ssh \
164 $RPM_BUILD_ROOT/var/adm/fillup-templates
167 cd x11-ssh-askpass-%{xversion}
169 rm -f $RPM_BUILD_ROOT/usr/share/Ssh.bin
173 rm -rf $RPM_BUILD_ROOT
176 /usr/sbin/groupadd -g %{sshd_gid} -o -r sshd 2> /dev/null || :
177 /usr/sbin/useradd -r -o -g sshd -u %{sshd_uid} -s /bin/false -c "SSH Privilege Separation User" -d …
180 /usr/bin/ssh-keygen -A
181 %{fillup_and_insserv -n -y ssh sshd}
185 %verify_permissions -e /etc/ssh/sshd_config -e /etc/ssh/ssh_config -e /usr/bin/ssh
195 %defattr(-,root,root)
204 %attr(0755,root,root) %{_bindir}/ssh-keygen
207 %attr(0755,root,root) %{_bindir}/ssh-agent
208 %attr(0755,root,root) %{_bindir}/ssh-add
209 %attr(0755,root,root) %{_bindir}/ssh-keyscan
213 %attr(0755,root,root) %{_libdir}/ssh/sftp-server
214 %attr(4711,root,root) %{_libdir}/ssh/ssh-keysign
215 %attr(0755,root,root) %{_libdir}/ssh/ssh-pkcs11-helper
216 %attr(0755,root,root) %{_libdir}/ssh/ssh-sk-helper
220 %attr(0644,root,root) %doc %{_mandir}/man1/ssh-add.1*
221 %attr(0644,root,root) %doc %{_mandir}/man1/ssh-agent.1*
222 %attr(0644,root,root) %doc %{_mandir}/man1/ssh-keygen.1*
223 %attr(0644,root,root) %doc %{_mandir}/man1/ssh-keyscan.1*
227 %attr(0644,root,root) %doc %{_mandir}/man8/sftp-server.8*
228 %attr(0644,root,root) %doc %{_mandir}/man8/ssh-keysign.8*
229 %attr(0644,root,root) %doc %{_mandir}/man8/ssh-pkcs11-helper.8*
230 %attr(0644,root,root) %doc %{_mandir}/man8/ssh-sk-helper.8*
232 %attr(0644,root,root) /var/adm/fillup-templates/sysconfig.ssh
236 %defattr(-,root,root)
237 %doc x11-ssh-askpass-%{xversion}/README
238 %doc x11-ssh-askpass-%{xversion}/ChangeLog
239 %doc x11-ssh-askpass-%{xversion}/SshAskpass*.ad
240 %attr(0755,root,root) %{_libdir}/ssh/ssh-askpass
241 %attr(0755,root,root) %{_libdir}/ssh/x11-ssh-askpass
242 %attr(0644,root,root) %doc /usr/X11R6/man/man1/ssh-askpass.1x*
243 %attr(0644,root,root) %doc /usr/X11R6/man/man1/x11-ssh-askpass.1x*
244 %attr(0644,root,root) %config /usr/X11R6/lib/X11/app-defaults/SshAskpass