Lines Matching +full:0 +full:- +full:mon
8 # Version of ssh-askpass
11 # Do we want to disable building of x11-askpass? (1=yes 0=no)
12 %global no_x11_askpass 0
14 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
15 %global no_gnome_askpass 0
17 # Do we want to link against a static libcrypto? (1=yes 0=no)
18 %global static_libcrypto 0
20 # Do we want smartcard support (1=yes 0=no)
21 %global scard 0
23 # Use GTK2 instead of GNOME in gnome-ssh-askpass
28 %if 0%{?rhel} > 6
29 %global build6x 0
34 %global without_openssl 0
36 %if 0%{?fedora} <= 28
39 %if 0%{?rhel} <= 7
43 # Do we want kerberos5 support (1=yes 0=no)
47 # rpm -ba|--rebuild --define 'skip_xxx 1'
53 # rpm -ba|--rebuild --define 'no_gtk2 1'
54 %{?no_gtk2:%global gtk2 0}
65 # rpm -ba|--rebuild --define "static_openssl 1"
68 # Options for Smartcard support: (needs libsectok and openssl-engine)
69 # rpm -ba|--rebuild --define "smartcard 1"
72 # Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
73 %global rescue 0
78 %global kerberos5 0
90 Source0: https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
91 Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
94 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
103 BuildRequires: openssl-devel >= 1.1.1
107 BuildRequires: glibc-devel, pam
114 BuildRequires: libXt-devel
118 BuildRequires: gtk2-devel
124 BuildRequires: krb5-devel
125 BuildRequires: krb5-libs
130 Requires: openssh = %{version}-%{release}
132 Obsoletes: ssh-clients
137 Obsoletes: ssh-server
138 Requires: openssh = %{version}-%{release}, chkconfig >= 0.9
140 Requires: /etc/pam.d/system-auth
146 Requires: openssh = %{version}-%{release}
147 Obsoletes: ssh-extras
149 %package askpass-gnome
152 Requires: openssh = %{version}-%{release}
153 Obsoletes: ssh-extras
168 install openssh-clients, openssh-server, or both.
188 %description askpass-gnome
197 %setup -q -a 1
199 %setup -q
204 CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
208 --sysconfdir=%{_sysconfdir}/ssh \
209 --libexecdir=%{_libexecdir}/openssh \
210 --datadir=%{_datadir}/openssh \
211 --with-default-path=/usr/local/bin:/bin:/usr/bin \
212 --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
213 --with-privsep-path=%{_var}/empty/sshd \
214 --mandir=%{_mandir} \
215 --with-mantype=man \
216 --disable-strip \
218 --without-openssl \
221 --with-smartcard \
224 --without-pam \
226 --with-pam \
229 --with-kerberos5=$K5DIR \
234 perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
240 pushd x11-ssh-askpass-%{aversion}
241 %configure --libexecdir=%{_libexecdir}/openssh
242 xmkmf -a
258 make gnome-ssh-askpass2
259 mv gnome-ssh-askpass2 gnome-ssh-askpass
261 make gnome-ssh-askpass1
262 mv gnome-ssh-askpass1 gnome-ssh-askpass
268 rm -rf $RPM_BUILD_ROOT
269 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
270 mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
271 mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
275 install -d $RPM_BUILD_ROOT/etc/pam.d/
276 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
277 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
278 install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
279 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
282 install x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-a…
283 ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
287 install contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
291 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
295 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
296 install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
297 install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
300 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
303 rm -rf $RPM_BUILD_ROOT
305 %triggerun server -- ssh-server
306 if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
310 %triggerun server -- openssh-server < 2.5.0p1
319 if [ $? -eq 1 ] ; then
324 %triggerpostun server -- ssh-server
325 if [ "$1" != 0 ] ; then
326 /sbin/chkconfig --add sshd
327 if test -f /var/run/sshd.restart ; then
328 rm -f /var/run/sshd.restart
334 %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
335 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
336 -g sshd -M -r sshd 2>/dev/null || :
339 /sbin/chkconfig --add sshd
345 if [ "$1" = 0 ]
348 /sbin/chkconfig --del sshd
352 %defattr(-,root,root)
359 %attr(0755,root,root) %{_bindir}/ssh-keygen
360 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
362 %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
363 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
364 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-sk-helper
365 %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
366 %attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
367 %attr(0644,root,root) %{_mandir}/man8/ssh-sk-helper.8*
375 %defattr(-,root,root)
381 %attr(2755,root,nobody) %{_bindir}/ssh-agent
382 %attr(0755,root,root) %{_bindir}/ssh-add
383 %attr(0755,root,root) %{_bindir}/ssh-keyscan
385 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
386 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
387 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
393 %defattr(-,root,root)
396 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
400 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
409 %defattr(-,root,root)
410 %doc x11-ssh-askpass-%{aversion}/README
411 %doc x11-ssh-askpass-%{aversion}/ChangeLog
412 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
413 %{_libexecdir}/openssh/ssh-askpass
414 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
418 %files askpass-gnome
419 %defattr(-,root,root)
420 %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
421 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
425 * Mon Oct 16 2023 Fabio Pedretti <pedretti.fabio@gmail.com>
426 - Remove reference of dropped sshd.pam.old file
427 - Update openssl-devel dependency to require >= 1.1.1
428 - Build with --without-openssl elsewhere
431 - Remove remaining traces of --with-md5-passwords
433 * Mon Jul 20 2020 Damien Miller <djm@mindrot.org>
434 - Add ssh-sk-helper and corresponding manual page.
437 - Update openssl-devel dependency to match current requirements.
438 - Handle Fedora >=6 openssl 1.0 compat libs.
439 - Remove SSH1 from description.
440 - Don't strip binaries at build time so that debuginfo package can be
443 * Sun Nov 16 2014 Nico Kadel-Garcia <nakdel@gmail.com>
444 - Add '--mandir' and '--with-mantype' for RHEL 5 compatibility
445 - Add 'dist' option to 'ver' so package names reflect OS at build time
446 - Always include x11-ssh-askpass tarball in SRPM
447 - Add openssh-x11-aspass BuildRequires for libXT-devel, imake, gtk2-devel
448 - Discard 'K5DIR' reporting, not usable inside 'mock' for RHEL 5 compatibility
449 - Discard obsolete '--with-rsh' configure option
450 - Update openssl-devel dependency to 0.9.8f, as found in autoconf
453 - test for skip_x11_askpass (line 77) should have been for no_x11_askpass
455 * Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
456 - Remove noip6 option. This may be controlled at run-time in client config
459 * Mon May 12 2003 Damien Miller <djm@mindrot.org>
460 - Don't install profile.d scripts when not building with GNOME/GTK askpass
464 - Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
466 * Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
467 - Use contrib/ Makefile for building askpass programs
470 - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
471 - Add new {ssh,sshd}_config.5 manpages
472 - Add new ssh-keysign program and remove setuid from ssh client
475 - Merge in spec changes from RedHat, reorgansie a little
476 - Add Privsep user, group and directory
478 * Thu Mar 7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
479 - bump and grind (through the build system)
481 * Thu Mar 7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
482 - require sharutils for building (mindrot #137)
483 - require db1-devel only when building for 6.x (#55105), which probably won't
485 - require pam-devel by file (not by package name) again
486 - add Markus's patch to compile with OpenSSL 0.9.5a (from
490 * Thu Mar 7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
491 - update to 3.1p1
493 * Tue Mar 5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
494 - update to SNAP-20020305
495 - drop debug patch, fixed upstream
497 * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
498 - update to SNAP-20020220 for testing purposes (you've been warned, if there's
501 * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
502 - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
505 * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
506 - remove dependency on db1-devel, which has just been swallowed up whole
507 by gnome-libs-devel
510 - adjust build dependencies so that build6x actually works right (fix
513 * Tue Dec 4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
514 - update to 3.0.2p1
516 * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
517 - update to 3.0.1p1
520 - update to current CVS (not for use in distribution)
522 * Thu Nov 8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
523 - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
527 - update to 3.0p1
528 - update to x11-ssh-askpass 1.2.4.1
529 - change build dependency on a file from pam-devel to the pam-devel package
530 - replace primes with moduli
532 * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
533 - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
535 * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
536 - Merge changes to rescue build from current sysadmin survival cd
538 * Thu Sep 6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
539 - fix scp's server's reporting of file sizes, and build with the proper
540 preprocessor define to get large-file capable open(), stat(), etc.
542 - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
543 - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
544 - mark profile.d scriptlets as config files (#42337)
545 - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
546 - change a couple of log() statements to debug() statements (#50751)
547 - pull cvs patch to add -t flag to sshd (#28611)
548 - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
550 * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
551 - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
554 - pull cvs patch to fix remote port forwarding with protocol 2
557 - pull cvs patch to add session initialization to no-pty sessions
558 - pull cvs patch to not cut off challengeresponse auth needlessly
559 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
563 - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
565 * Mon Aug 6 2001 Nalin Dahyabhai <nalin@redhat.com>
566 - pass OPTIONS correctly to initlog (#50151)
569 - switch to x11-ssh-askpass 1.2.2
572 - rebuild in new environment
574 * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
575 - disable the gssapi patch
577 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
578 - update to 2.9p2
579 - refresh to a new version of the gssapi patch
582 - change Copyright: BSD to License: BSD
583 - add Markus Friedl's unverified patch for the cookie file deletion problem
585 - drop patch to check if xauth is present (was folded into cookie patch)
586 - don't apply gssapi patches for the errata candidate
587 - clear supplemental groups list at startup
590 - fix an error parsing the new default sshd_config
591 - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
595 - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
600 - finish marking strings in the init script for translation
601 - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
604 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
608 - update to 2.9
609 - drop various patches that came from or went upstream or to or from CVS
612 - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
615 - remove explicit openssl requirement, fixes builddistro issue
616 - make initscript stop() function wait until sshd really dead to avoid
619 * Mon Apr 2 2001 Nalin Dahyabhai <nalin@redhat.com>
620 - mention that challengereponse supports PAM, so disabling password doesn't
622 - bypass the daemon() function in the init script and call initlog directly,
625 - require the version of openssl we had when we were built
628 - make do_pam_setcred() smart enough to know when to establish creds and
630 - add in a couple of other fixes from Damien for inclusion in the errata
633 - update to 2.5.2p2
634 - call setcred() again after initgroups, because the "creds" could actually
638 - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
639 - don't enable challenge-response by default until we find a way to not
642 - remove build dependency on rsh to match openssh.com's packages more closely
645 - remove dependency on openssl -- would need to be too precise
648 - rebuild in new environment
650 * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
651 - Revert the patch to move pam_open_session.
652 - Init script and spec file changes from Pekka Savola. (#28750)
653 - Patch sftp to recognize '-o protocol' arguments. (#29540)
656 - Chuck the closing patch.
657 - Add a trigger to add host keys for protocol 2 to the config file, now that
662 - Redo patch to move pam_open_session after the server setuid()s to the user.
663 - Rework the nopam patch to use be picked up by autoconf.
665 * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
666 - Update for 2.5.1p1.
667 - Add init script mods from Pekka Savola.
668 - Tweak the init script to match the CVS contrib script more closely.
669 - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
673 - Update for 2.5.0p1.
674 - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
675 - Resync with parts of Damien Miller's openssh.spec from CVS, including
676 update of x11 askpass to 1.2.0.
677 - Only require openssl (don't prereq) because we generate keys in the init
681 - Don't open a PAM session until we've forked and become the user (#25690).
682 - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
684 - Resync with parts of Damien Miller's openssh.spec from CVS.
685 - Don't expose KbdInt responses in debug messages (from CVS).
686 - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
689 - i18n-tweak to initscript.
692 - More gettextizing.
693 - Close all files after going into daemon mode (needs more testing).
694 - Extract patch from CVS to handle auth banners (in the client).
695 - Extract patch from CVS to handle compat weirdness.
698 - Finish with the gettextizing.
701 - Fix a bug in auth2-pam.c (#23877)
702 - Gettextize the init script.
705 - Incorporate a switch for using PAM configs for 6.x, just in case.
708 - Incorporate Bero's changes for a build specifically for rescue CDs.
711 - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
712 succeeded, to allow public-key authentication after a failure with "none"
716 - Update to x11-askpass 1.1.1. (#21301)
717 - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
719 * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
720 - Merge multiple PAM text messages into subsequent prompts when possible when
721 doing keyboard-interactive authentication.
724 - Disable the built-in MD5 password support. We're using PAM.
725 - Take a crack at doing keyboard-interactive authentication with PAM, and
728 - Build with debugging flags. Build root policies strip all binaries anyway.
731 - Use DESTDIR instead of %%makeinstall.
732 - Remove /usr/X11R6/bin from the path-fixing patch.
734 * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
735 - Add the primes file from the latest snapshot to the main package (#20884).
736 - Add the dev package to the prereq list (#19984).
737 - Remove the default path and mimic login's behavior in the server itself.
740 - Resync with conditional options in Damien Miller's .spec file for an errata.
741 - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
744 - Update to OpenSSH 2.3.0p1.
745 - Update to x11-askpass 1.1.0.
746 - Enable keyboard-interactive authentication.
748 * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
749 - Update to ssh-askpass-x11 1.0.3.
750 - Change authentication related messages to be private (#19966).
753 - Patch ssh-keygen to be able to list signatures for DSA public key files
757 - Add BuildRequires on /usr/include/security/pam_appl.h to be sure we always
759 - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
760 - Clean out no-longer-used patches.
761 - Patch ssh-add to try to add both identity and id_dsa, and to error only
764 * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
765 - Update x11-askpass to 1.0.2. (#17835)
766 - Add BuildRequiress for /bin/login and /usr/bin/rsh so that configure will
768 - Set the default path to be the same as the one supplied by /bin/login, but
770 - Try to handle obsoletion of ssh-server more cleanly. Package names
774 - Update to 2.2.0p1. (#17835)
775 - Tweak the init script to allow proper restarting. (#18023)
778 - Update to 20000823 snapshot.
779 - Change subpackage requirements from %%{version} to %%{version}-%%{release}
780 - Back out the pipe patch.
782 * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
783 - Update to 2.1.1p4, which includes fixes for config file parsing problems.
784 - Move the init script back.
785 - Add Damien's quick fix for wackiness.
788 - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
791 - Move condrestart to server postun.
792 - Move key generation to init script.
793 - Actually use the right patch for moving the key generation to the init script.
794 - Clean up the init script a bit.
797 - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
800 - Update to 2.1.1p2.
801 - Use of strtok() considered harmful.
804 - Get the build root out of the man pages.
807 - Add and use condrestart support in the init script.
808 - Add newer initscripts as a prereq.
811 - Build in new environment (release 2)
812 - Move -clients subpackage to Applications/Internet group
815 - Update to 2.2.1p1
818 - Patch to build with neither RSA nor RSAref.
819 - Miscellaneous FHS-compliance tweaks.
820 - Fix for possibly-compressed man pages.
823 - Updated for new location
824 - Updated for new gnome-ssh-askpass build
827 - Added Jim Knoble's <jmknoble@pobox.com> askpass
829 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
830 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
833 - Added 'Obsoletes' directives
836 - Use make install
837 - Subpackages
839 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
840 - Added links for slogin
841 - Fixed perms on manpages
844 - Renamed init script
847 - Back to old binary names
850 - Use autoconf
851 - New binary names
854 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.