#
95882b98 |
| 23-Jun-2010 |
Konstantin Belousov <kib@FreeBSD.org> |
Remove unused i586 optimized bcopy/bzero/etc implementations that utilize FPU registers for copying. Remove the switch table and jumps from bcopy/bzero/... to the actual implementation. As a side-eff
Remove unused i586 optimized bcopy/bzero/etc implementations that utilize FPU registers for copying. Remove the switch table and jumps from bcopy/bzero/... to the actual implementation. As a side-effect, i486-optimized bzero is removed.
Reviewed by: bde Tested by: pho (previous version)
show more ...
|
Revision tags: release/7.3.0_cvs, release/7.3.0 |
|
#
1a0fda2b |
| 04-Mar-2010 |
Dag-Erling Smørgrav <des@FreeBSD.org> |
IFH@204581
|
#
9199c09a |
| 06-Jan-2010 |
Warner Losh <imp@FreeBSD.org> |
Merge from head at r201628.
# This hasn't been tested, and there are at least three bad commits # that need to be backed out before the branch will be stable again.
|
#
cfd7bace |
| 29-Dec-2009 |
Robert Noland <rnoland@FreeBSD.org> |
Update d_mmap() to accept vm_ooffset_t and vm_memattr_t.
This replaces d_mmap() with the d_mmap2() implementation and also changes the type of offset to vm_ooffset_t.
Purge d_mmap2().
All driver m
Update d_mmap() to accept vm_ooffset_t and vm_memattr_t.
This replaces d_mmap() with the d_mmap2() implementation and also changes the type of offset to vm_ooffset_t.
Purge d_mmap2().
All driver modules will need to be rebuilt since D_VERSION is also bumped.
Reviewed by: jhb@ MFC after: Not in this lifetime...
show more ...
|
Revision tags: release/8.0.0_cvs, release/8.0.0, release/7.2.0_cvs, release/7.2.0, release/7.1.0_cvs, release/7.1.0, release/6.4.0_cvs, release/6.4.0, release/7.0.0_cvs, release/7.0.0, release/6.3.0_cvs, release/6.3.0 |
|
#
9336e069 |
| 30-Dec-2007 |
Wojciech A. Koszek <wkoszek@FreeBSD.org> |
Replace explicit calls to video methods with their respective variants implemented with macros. This patch improves code readability. Reasoning behind vidd_* is a sort of "video discipline".
List of
Replace explicit calls to video methods with their respective variants implemented with macros. This patch improves code readability. Reasoning behind vidd_* is a sort of "video discipline".
List of macros is supposed to be complete--all methods of video_switch ought to have their respective macros from now on.
Functionally, this code should be no-op. My intention is to leave current behaviour of touched code as is.
No objections: rwatson Silence on: freebsd-current@ Approved by: cognet
show more ...
|
#
2f11f337 |
| 18-Jan-2007 |
Marius Strobl <marius@FreeBSD.org> |
On sparc64 also use the fillw() this header provides for ia64 so the sparc64 MD code doesn't need to provide a memsetw() along with the ISA compat cruft.
|
Revision tags: release/6.2.0_cvs, release/6.2.0, release/5.5.0_cvs, release/5.5.0, release/6.1.0_cvs, release/6.1.0 |
|
#
44e09d2f |
| 06-Dec-2005 |
Ruslan Ermilov <ru@FreeBSD.org> |
Fix -Wundef warnings from compiling GENERIC and LINT kernels of all architectures.
|
Revision tags: release/6.0.0_cvs, release/6.0.0 |
|
#
b7c96c0d |
| 28-Sep-2005 |
Marius Strobl <marius@FreeBSD.org> |
Add a font width argument to vi_load_font_t, vi_save_font_t and vi_putm_t and do some preparations for handling 12x22 fonts (currently lots of code implies and/or hardcodes a font width of 8 pixels).
Add a font width argument to vi_load_font_t, vi_save_font_t and vi_putm_t and do some preparations for handling 12x22 fonts (currently lots of code implies and/or hardcodes a font width of 8 pixels). This will be required on sparc64 which uses a default font size of 12x22 in order to add font loading and saving support as well as to use a syscons(4)-supplied mouse pointer image. This API breakage is committed now so it can be MFC'ed in time for 6.0 and later on upcoming framebuffer drivers destined for use on sparc64 and which are expected to rely on using font loading internally and on a syscons(4)-supplied mouse pointer image can be easily MFC'ed to RELENG_6 rather than requiring a backport.
Tested on: i386, sparc64, make universe MFC after: 1 week
show more ...
|
Revision tags: release/5.4.0_cvs, release/5.4.0, release/4.11.0_cvs, release/4.11.0, release/5.3.0_cvs, release/5.3.0, release/4.10.0_cvs, release/4.10.0, release/5.2.1_cvs, release/5.2.1 |
|
#
a2dce78a |
| 21-Jan-2004 |
Peter Grehan <grehan@FreeBSD.org> |
__powerpc__ conditional code for the syscons OpenFirmware/PPC framebuffer. Took the opportunity to reduce
__i386__ || __ia64__ || __amd64__ || __sparc64__ || __powerpc__
to
!__alpha__
reviewed
__powerpc__ conditional code for the syscons OpenFirmware/PPC framebuffer. Took the opportunity to reduce
__i386__ || __ia64__ || __amd64__ || __sparc64__ || __powerpc__
to
!__alpha__
reviewed by: gallatin
show more ...
|
Revision tags: release/5.2.0_cvs, release/5.2.0, release/4.9.0_cvs, release/4.9.0 |
|
#
4866f95d |
| 26-Sep-2003 |
Poul-Henning Kamp <phk@FreeBSD.org> |
Change fb_attach() and fb_detach() to take a integer unit number rather than a dev_t.
All of the dev_t's passed were bogusly created with makedev()
|
#
fe9d118a |
| 23-Aug-2003 |
Marcel Moolenaar <marcel@FreeBSD.org> |
o Explicitly cast the second argument to bus_space_set_region_#() to intptr_t. This fixes a compiler warning (integer from pointer without cast) in scvgarndr.c when SC_PIXEL_MODE is defined. o
o Explicitly cast the second argument to bus_space_set_region_#() to intptr_t. This fixes a compiler warning (integer from pointer without cast) in scvgarndr.c when SC_PIXEL_MODE is defined. o Define readb() and writeb(). Both are used in scvgarndr.c when, guess what, SC_PIXEL_MODE is defined.
Both changes are ia64 specific.
Found by: LINT
show more ...
|
Revision tags: release/5.1.0_cvs, release/5.1.0 |
|
#
8c376570 |
| 01-May-2003 |
Peter Wemm <peter@FreeBSD.org> |
Add AMD64 support to dev/fb. It isn't optimized.
|
#
0ba311ef |
| 29-Apr-2003 |
Marcel Moolenaar <marcel@FreeBSD.org> |
Keep syscons specific I/O functions internal/specific to syscons on ia64 by defining them in terms of newbus. Add a static inline for fillw(), which doesn't have anything to do with I/O. It's still u
Keep syscons specific I/O functions internal/specific to syscons on ia64 by defining them in terms of newbus. Add a static inline for fillw(), which doesn't have anything to do with I/O. It's still ugly, but now the ugliness can be removed from ia64 specific headers.
show more ...
|
Revision tags: release/4.8.0_cvs, release/4.8.0 |
|
#
227f9a1c |
| 25-Mar-2003 |
Jake Burkholder <jake@FreeBSD.org> |
- Add vm_paddr_t, a physical address type. This is required for systems where physical addresses larger than virtual addresses, such as i386s with PAE. - Use this to represent physical addresses
- Add vm_paddr_t, a physical address type. This is required for systems where physical addresses larger than virtual addresses, such as i386s with PAE. - Use this to represent physical addresses in the MI vm system and in the i386 pmap code. This also changes the paddr parameter to d_mmap_t. - Fix printf formats to handle physical addresses >4G in the i386 memory detection code, and due to kvtop returning vm_paddr_t instead of u_long.
Note that this is a name change only; vm_paddr_t is still the same as vm_offset_t on all currently supported platforms.
Sponsored by: DARPA, Network Associates Laboratories Discussed with: re, phk (cdevsw change)
show more ...
|
#
07159f9c |
| 25-Feb-2003 |
Maxime Henrion <mux@FreeBSD.org> |
Cleanup of the d_mmap_t interface.
- Get rid of the useless atop() / pmap_phys_address() detour. The device mmap handlers must now give back the physical address without atop()'ing it. - Don't
Cleanup of the d_mmap_t interface.
- Get rid of the useless atop() / pmap_phys_address() detour. The device mmap handlers must now give back the physical address without atop()'ing it. - Don't borrow the physical address of the mapping in the returned int. Now we properly pass a vm_offset_t * and expect it to be filled by the mmap handler when the mapping was successful. The mmap handler must now return 0 when successful, any other value is considered as an error. Previously, returning -1 was the only way to fail. This change thus accidentally fixes some devices which were bogusly returning errno constants which would have been considered as addresses by the device pager. - Garbage collect the poorly named pmap_phys_address() now that it's no longer used. - Convert all the d_mmap_t consumers to the new API.
I'm still not sure wheter we need a __FreeBSD_version bump for this, since and we didn't guarantee API/ABI stability until 5.1-RELEASE.
Discussed with: alc, phk, jake Reviewed by: peter Compile-tested on: LINT (i386), GENERIC (alpha and sparc64) Runtime-tested on: i386
show more ...
|
Revision tags: release/5.0.0_cvs, release/5.0.0, release/4.7.0_cvs, release/4.6.2_cvs, release/4.6.2, release/4.6.1, release/4.6.0_cvs |
|
#
0301e9c8 |
| 14-Apr-2002 |
David E. O'Brien <obrien@FreeBSD.org> |
Turn on TGA support.
Submitted by: Andrew M. Miklic <AndrwMklc@cs.com>
|
Revision tags: release/4.5.0_cvs, release/4.4.0_cvs |
|
#
b1511f4f |
| 06-Nov-2001 |
Dag-Erling Smørgrav <des@FreeBSD.org> |
syscons' set_border() is now named sc_set_border(), so there is no longer a naming conflict.
|
#
b40ce416 |
| 12-Sep-2001 |
Julian Elischer <julian@FreeBSD.org> |
KSE Milestone 2 Note ALL MODULES MUST BE RECOMPILED make the kernel aware that there are smaller units of scheduling than the process. (but only allow one thread per process at this time). This is fu
KSE Milestone 2 Note ALL MODULES MUST BE RECOMPILED make the kernel aware that there are smaller units of scheduling than the process. (but only allow one thread per process at this time). This is functionally equivalent to teh previousl -current except that there is a thread associated with each process.
Sorry john! (your next MFC will be a doosie!)
Reviewed by: peter@freebsd.org, dillon@freebsd.org
X-MFC after: ha ha ha ha
show more ...
|
#
6d169958 |
| 02-Aug-2001 |
Kazutaka YOKOTA <yokota@FreeBSD.org> |
Add some definitions. Their actual support will be added to video drivers later.
|
#
f41325db |
| 13-Jun-2001 |
Peter Wemm <peter@FreeBSD.org> |
With this commit, I hereby pronounce gensetdefs past its use-by date.
Replace the a.out emulation of 'struct linker_set' with something a little more flexible. <sys/linker_set.h> now provides macro
With this commit, I hereby pronounce gensetdefs past its use-by date.
Replace the a.out emulation of 'struct linker_set' with something a little more flexible. <sys/linker_set.h> now provides macros for accessing elements and completely hides the implementation.
The linker_set.h macros have been on the back burner in various forms since 1998 and has ideas and code from Mike Smith (SET_FOREACH()), John Polstra (ELF clue) and myself (cleaned up API and the conversion of the rest of the kernel to use it).
The macros declare a strongly typed set. They return elements with the type that you declare the set with, rather than a generic void *.
For ELF, we use the magic ld symbols (__start_<setname> and __stop_<setname>). Thanks to Richard Henderson <rth@redhat.com> for the trick about how to force ld to provide them for kld's.
For a.out, we use the old linker_set struct.
NOTE: the item lists are no longer null terminated. This is why the code impact is high in certain areas.
The runtime linker has a new method to find the linker set boundaries depending on which backend format is in use.
linker sets are still module/kld unfriendly and should never be used for anything that may be modular one day.
Reviewed by: eivind
show more ...
|
Revision tags: release/4.3.0_cvs, release/4.3.0, release/4.2.0, release/4.1.1_cvs, release/4.1.0, release/3.5.0_cvs, release/4.0.0_cvs |
|
#
664a31e4 |
| 29-Dec-1999 |
Peter Wemm <peter@FreeBSD.org> |
Change #ifdef KERNEL to #ifdef _KERNEL in the public headers. "KERNEL" is an application space macro and the applications are supposed to be free to use it as they please (but cannot). This is cons
Change #ifdef KERNEL to #ifdef _KERNEL in the public headers. "KERNEL" is an application space macro and the applications are supposed to be free to use it as they please (but cannot). This is consistant with the other BSD's who made this change quite some time ago. More commits to come.
show more ...
|
Revision tags: release/3.4.0_cvs, release/3.3.0_cvs |
|
#
c3aac50f |
| 28-Aug-1999 |
Peter Wemm <peter@FreeBSD.org> |
$Id$ -> $FreeBSD$
|
#
6e8394b8 |
| 22-Jun-1999 |
Kazutaka YOKOTA <yokota@FreeBSD.org> |
The second phase of syscons reorganization.
- Split syscons source code into manageable chunks and reorganize some of complicated functions.
- Many static variables are moved to the softc structu
The second phase of syscons reorganization.
- Split syscons source code into manageable chunks and reorganize some of complicated functions.
- Many static variables are moved to the softc structure.
- Added a new key function, PREV. When this key is pressed, the vty immediately before the current vty will become foreground. Analogue to PREV, which is usually assigned to the PrntScrn key. PR: kern/10113 Submitted by: Christian Weisgerber <naddy@mips.rhein-neckar.de>
- Modified the kernel console input function sccngetc() so that it handles function keys properly.
- Reorganized the screen update routine.
- VT switching code is reorganized. It now should be slightly more robust than before.
- Added the DEVICE_RESUME function so that syscons no longer hooks the APM resume event directly.
- New kernel configuration options: SC_NO_CUTPASTE, SC_NO_FONT_LOADING, SC_NO_HISTORY and SC_NO_SYSMOUSE. Various parts of syscons can be omitted so that the kernel size is reduced.
SC_PIXEL_MODE Made the VESA 800x600 mode an option, rather than a standard part of syscons.
SC_DISABLE_DDBKEY Disables the `debug' key combination.
SC_ALT_MOUSE_IMAGE Inverse the character cell at the mouse cursor position in the text console, rather than drawing an arrow on the screen. Submitted by: Nick Hibma (n_hibma@FreeBSD.ORG)
SC_DFLT_FONT makeoptions "SC_DFLT_FONT=_font_name_" Include the named font as the default font of syscons. 16-line, 14-line and 8-line font data will be compiled in. This option replaces the existing STD8X16FONT option, which loads 16-line font data only.
- The VGA driver is split into /sys/dev/fb/vga.c and /sys/isa/vga_isa.c.
- The video driver provides a set of ioctl commands to manipulate the frame buffer.
- New kernel configuration option: VGA_WIDTH90 Enables 90 column modes: 90x25, 90x30, 90x43, 90x50, 90x60. These modes are mot always supported by the video card. PR: i386/7510 Submitted by: kbyanc@freedomnet.com and alexv@sui.gda.itesm.mx.
- The header file machine/console.h is reorganized; its contents is now split into sys/fbio.h, sys/kbio.h (a new file) and sys/consio.h (another new file). machine/console.h is still maintained for compatibility reasons.
- Kernel console selection/installation routines are fixed and slightly rebumped so that it should now be possible to switch between the interanl kernel console (sc or vt) and a remote kernel console (sio) again, as it was in 2.x, 3.0 and 3.1.
- Screen savers and splash screen decoders Because of the header file reorganization described above, screen savers and splash screen decoders are slightly modified. After this update, /sys/modules/syscons/saver.h is no longer necessary and is removed.
show more ...
|
Revision tags: release/3.2.0 |
|
#
601752d5 |
| 12-Apr-1999 |
Dag-Erling Smørgrav <des@FreeBSD.org> |
Centralize and reorganize a few macros.
|
Revision tags: release/3.1.0, release/3.0.0, release/2.2.8 |
|
#
f359876f |
| 19-Jan-1999 |
Kazutaka YOKOTA <yokota@FreeBSD.org> |
syscons - Bring down the splash screen when a vty is opened for the first time. - Make sure the splash screen/screen saver is stopped before switching vtys. - Read and save initial values in the
syscons - Bring down the splash screen when a vty is opened for the first time. - Make sure the splash screen/screen saver is stopped before switching vtys. - Read and save initial values in the BIOS data area early. VESA BIOS may change BIOS data values when switching modes. - Fix missing '&' operator. - Move ISA specific part of driver initialization to syscons_isa.c.
atkbd - kbdtables.h is now in /sys/dev/kbd.
all - Adjust for forthcoming alpha port. Submitted by: dfr
show more ...
|